Opened 14 months ago

Closed 9 months ago

#14027 closed bug (duplicate)

[Network] DHCP configuration problematic

Reported by: al_xv Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/net_server Version: R1/Development
Keywords: Cc:
Blocked By: #13904 Blocking:
Has a Patch: no Platform: All

Description

Current Behavior:

Recently installed HREV51808 updated from R1A4. On first boot after installation I opened ActivityMonitor and noticed the network TX/RX graph (wired ethernet - see screenshot) displaying constant activity with consistent data rate.

I attempted to open up the Network prefs from the NetworkStatus icon on the Deskbar and after a moment received a crash dialog (reported as ticket https://dev.haiku-os.org/ticket/14014).

I opened the Network prefs again and changed the ipv4 to Static.

I rebooted to see if it was a fluke and the activity continued as before. I opened the Network prefs again and changed the ipv4 to Static but entered correct addresses and netmask before hitting apply. However, the ActivityMonitor graph was still showing lots of network activity unchanged since I applied the static address. Additionally I have my ethernet switch infront of me and could see continuous boradcast activity on my network from this machine. I then unplugged the ethernet cable and noticed the ActivityMonitor graph continuing to show the same network activity.

I decided to open my syslog file and found the most recent entries were a repetition of mainly these two lines:

DAEMON 'DHCP': /dev/net/ipro100/0: Send DHCP_REQUEST to 255.255.255.255:67
DAEMON 'DHCP': /dev/net/ipro100/0: Send DHCP_DISCOVER to 255.255.255.255:67

...As I went to close Network Preferences, it locked up (unable to quit), so I rebooted again.

On the following startup, my network activity graph showed no constant activity and I found my static ipv4 configuration settings were saved and being used. From here I re-connected my ethernet and didn't have any problems connecting to external servers. Additionally nothing in my network changed when I switched to HREV51808.

Expected Behavior:

Under R1A4, I didn't have any issues like this. DHCP assignment was straight forward and I don't think I adjusted network settings at all- basically plug and play.

Additional testing:

Changing settings back to DHCP did work as expected (addresses automatically assigned and no extra network activity) until reboot. On reboot, network activity once again started sending the DHCP requests broadcast on my network. I also had a look at ifconfig and noticed when DHCP was active and the network graph was displaying constant activity, I was also getting reports of thousands of TX packet errors.

I also tried connecting it to a different router for testing. The results with the alternate router were not quite the same. If I connected the 2nd router after Haiku was already in the DHCP loop- without chaging any settings, it would acquire an address and cease the erroneous activity. If I rebooted with the 2nd router attached, I would again see the problematic network activity related to DHCP.

It may be possible that my normal (1st) router is part of the problem (and sometimes I do have problems where it needs to be reset). However it was working without issue under R1A4, so this seems to be related to Haiku as well.

Workaround:

Once the static IP addresses are saved and machine is rebooted, network acts as expected.

Further research:

Diver recommended to open a new ticket, but the following tickets all share aspects of the problem I'm reporting: https://dev.haiku-os.org/ticket/12482 and/or https://dev.haiku-os.org/ticket/13904 and/or https://dev.haiku-os.org/ticket/13789.

Hardware:

Compaq Evo D510 (slim desktop) - Single Core P4 @ 1.9Ghz - 1gb ram

NIC:

Intel 82801DB Pro/100 VM (/dev/net/ipro100) No wireless hardware

Attachments (4)

activity_after_startup.png (142.8 KB) - added by al_xv 14 months ago.
Screenshot showing how activity starts after system has completed startup and desktop is initially shown
activity.png (176.4 KB) - added by al_xv 14 months ago.
Screenshot showing network activity and corresponding syslog entries.
ifconfig_errors.png (96.7 KB) - added by al_xv 14 months ago.
screenshot of transmit packet errors from ifconfig.
syslog+kd.txt (113.5 KB) - added by al_xv 14 months ago.
relevant syslog entries as well as debugger ints during undesired DHCP activity

Download all attachments as: .zip

Change History (6)

Changed 14 months ago by al_xv

Attachment: activity_after_startup.png added

Screenshot showing how activity starts after system has completed startup and desktop is initially shown

Changed 14 months ago by al_xv

Attachment: activity.png added

Screenshot showing network activity and corresponding syslog entries.

Changed 14 months ago by al_xv

Attachment: ifconfig_errors.png added

screenshot of transmit packet errors from ifconfig.

Changed 14 months ago by al_xv

Attachment: syslog+kd.txt added

relevant syslog entries as well as debugger ints during undesired DHCP activity

comment:1 Changed 10 months ago by waddlesplash

Component: - GeneralServers/net_server
Owner: changed from nobody to axeld

comment:2 Changed 9 months ago by waddlesplash

Blocked By: 13904 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.