Opened 6 months ago

Closed 4 months ago

Last modified 4 months ago

#14225 closed bug (fixed)

Partition gets wrong mount point after reboot

Reported by: KapiX Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: Servers/mount_server Version: R1/Development
Keywords: Cc: jessicah
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have a "Data" partition, that gets mounted under "/Dat" after boot. Desktop shows the name correctly, DriveSetup does as well, and if I unmount and mount it again, it gets mounted under "/Data".

I'm guessing automount changes broke this because I have never seen this before and it appeared after an update.

Attachments (1)

screenshot1.png (109.6 KB) - added by KapiX 6 months ago.

Download all attachments as: .zip

Change History (9)

Changed 6 months ago by KapiX

Attachment: screenshot1.png added

comment:1 Changed 5 months ago by KapiX

Milestone: UnscheduledR1/beta1
Owner: changed from stippi to axeld
Status: newassigned

comment:2 Changed 5 months ago by KapiX

I didn't manage to find the culprit myself, all I can tell is the name is saved correctly in settings (using message to inspect).

comment:3 Changed 5 months ago by jessicah

Cc: jessicah added

comment:4 Changed 5 months ago by axeld

It's likely that one of the recent user_strlcpy() fixes is causing that issue (there is probably one byte copied less now). Could you tell which file system your "Data" partition uses?

comment:5 Changed 5 months ago by waddlesplash

If you could test with an an older mountserver just before the changes on a new hrev, that would be helpful. That way we could just revert the patch in the beta branch if needed.

comment:6 Changed 5 months ago by KapiX

I will check. I have also upgraded my GCC2h install and I don't see that happening (on the same machine, Data being shared partition). The filesystem is BFS.

comment:7 Changed 5 months ago by waddlesplash

Oh. Someone mentioned that this may have been caused by the GCC upgrade; it would be very interesting (and probably a nightmare to track down) if that's the case. Could you try with one rev after / one rev before that?

comment:8 Changed 4 months ago by KapiX

Resolution: fixed
Status: assignedclosed

Fixed in hrev52179 and hrev52180.

Last edited 4 months ago by KapiX (previous) (diff)
Note: See TracTickets for help on using tickets.