Opened 12 years ago

Closed 12 years ago

#1423 closed bug (fixed)

App Network Preferences fails to recover gateway ip after reboot

Reported by: sicutdeux Owned by: axeld
Priority: normal Milestone: R1/alpha1
Component: Servers/net_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by stippi)

Gateway not added to routes on boot, but only when triggering the settings to be reloaded.

Change History (8)

comment:1 Changed 12 years ago by sicutdeux

Summary: App Network References fails to recover gateway ip after rebootApp Network Preferences fails to recover gateway ip after reboot

comment:2 Changed 12 years ago by axeld

Owner: changed from axeld to stippi

comment:3 Changed 12 years ago by stippi

The resolv.conf file should now be written if it doesn't exist yet. (hrev22366)

comment:4 Changed 12 years ago by stippi

Component: - Preferences/NetworkServers/net_server
Description: modified (diff)
Milestone: R1R1/alpha
Owner: changed from stippi to axeld

I investigated a bit, and this should be a net_server bug, not a bug of the Network preflet. With the exact same settings file: on boot, net_server fails to add the gateway route in manual settings mode. When the Network preflet is used to (re)write the exact same settings file, the gateway is added propery. At first I thought it might be a problem in which order the settins are applied (the gateway is considered as pretty much the first thing), I thought it might need the other settings to be originally applied to work, but moving the gateway stuff down as the last thing in NetServer.cpp didn't help.

comment:5 Changed 12 years ago by axeld

I guess we are talking about the manual configuration, and not DHCP?

comment:6 Changed 12 years ago by stippi

Yes, manual configuration, not DHCP.

comment:7 Changed 12 years ago by axeld

Status: newassigned

comment:8 Changed 12 years ago by axeld

Resolution: fixed
Status: assignedclosed

Fixed in hrev22723.

Note: See TracTickets for help on using tickets.