#14284 closed bug (fixed)

Possible Stability Issue Around First Load of HDS

Reported by: apl-haiku Owned by: apl-haiku
Priority: normal Milestone: Unscheduled
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There seems to be a problem reported by two people where the first load of the HaikuDepot application from a non-cached state is failing. This happening on a gcc2h environment. It happens sometimes. The problem is a seg-fault in;

BString::Compare(BString, BStrin
g&)

...from...

PackageCompare(const BReference<PackageInfo>&, const BReference<PackageInfo>&) + 0x56 (/boot/home/development/haiku/src/apps/haikudepot/../../../src/apps/haikudepot/model/PackageInfo.cpp:1102)
List<BReference<PackageInfo>,false,8>::_AddOrderedBounded(const BReference<PackageInfo>&, *, int32, int32) + 0x70 (/boot/home/development/haiku/src/apps/haikudepot/List.h:319)
List<BReference<PackageInfo>,false,8>::_AddOrderedBounded(const BReference<PackageInfo>&, *, int32, int32) + 0xae (/boot/home/development/haiku/src/apps/haikudepot/List.h:321)
List<BReference<PackageInfo>,false,8>::_AddOrderedBounded(const BReference<PackageInfo>&, *, int32, int32) + 0xae (/boot/home/development/haiku/src/apps/haikudepot/List.h:321)
(many frames the same -- maybe a clue)
List<BReference<PackageInfo>,fal
se,8>::AddOrdered(const BReference<PackageInfo>&, *) + 0x7b (/boot/home/development/haiku/src/apps/haikudepot/List.h:137)
DepotInfo::AddPackage(const BReference<PackageInfo>&) + 0x2b (/boot/home/development/haiku/src/apps/haikudepot/../../../src/apps/haikudepot/model/PackageInfo.cpp:1113)
MainWindow::_RefreshPackageList(bool) + 0xb0a (/boot/home/development/haiku/src/apps/haikudepot/../../../src/apps/haikudepot/ui/MainWindow.cpp:1072)

Change History (2)

comment:1 Changed 12 months ago by apl-haiku

It looks like I can reproduce the problem with a debug build; should be able to investigate further now.

comment:2 Changed 12 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Merged in hrev52116.

Note: See TracTickets for help on using tickets.