#14285 closed bug (duplicate)

Menus should avoid showing scroll arrows when opened on a window that is near the bottom of the screen if there is room above

Reported by: jscipione Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: User Interface Version: R1/Development
Keywords: Cc:
Blocked By: #9093 Blocking:
Has a Patch: no Platform: All

Description

This bug is easy to reproduce. Just take a window that has a menu bar, move it close to the bottom of the screen, but not too close, and then open up a menu from the menu bar. If you are really close to the bottom of the screen the menu will open above the menu bar (as it should), but if you are above some threshold (keep moving window up until you get there) above the window it will open the menu below the menu bar BUT with scroll arrows attached because it can't fit the whole menu between the top of the window and the bottom of the screen. Seeing this means you've triggered the bug.

Displaying scroll arrows here is silly because we don't need them, we already show the menu above the menu bar when you're a few pixels lower down the screen, we should do that here too because there is plenty of space above to show the menu. In the case that that is STILL not enough... only then should it show the scroll arrows.

This has been a bug for a long long time... since BeOS. I will attach screenshots showing the behavior happening on BeOS R5 and Haiku from 2015. We very successfully reproduced this not very great BeOS behavior.

Attachments (3)

menu_bottom_scroll.png (12.4 KB ) - added by jscipione 15 months ago.
bottom menu scroll-arrows bug in 2015-ish Haiku
BeOS menu bottom of screen bug.png (9.2 KB ) - added by jscipione 15 months ago.
bottom menu scroll-arrows bug in BeOS R5
expected behavior.png (41.5 KB ) - added by jscipione 15 months ago.
expected behavior: menu opens above the menu bar

Download all attachments as: .zip

Change History (5)

by jscipione, 15 months ago

Attachment: menu_bottom_scroll.png added

bottom menu scroll-arrows bug in 2015-ish Haiku

by jscipione, 15 months ago

bottom menu scroll-arrows bug in BeOS R5

by jscipione, 15 months ago

Attachment: expected behavior.png added

expected behavior: menu opens above the menu bar

comment:1 by idefix, 15 months ago

You also submitted this bug six years ago. ;)

comment:2 by jscipione, 15 months ago

Blocked By: 9093 added
Resolution: duplicate
Status: newclosed

Duplicate of #9093

So I did...

Note: See TracTickets for help on using tickets.