Opened 2 years ago

Last modified 4 days ago

#14298 reopened bug

[8086:3165] Intel iwm driver not loading for idualwifi7260

Reported by: mrentropy Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/idualwifi7260 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #15388, #15724
Platform: All

Description

Intel Wireless 3165 should be supported by the iwm driver. It currently fails on boot using 32-bit and 64-bit builds.

According to Waddlesplash, the issue is here:

KERN: [idualwifi7260] (iwm) fw chunk addr 0x800000 len 98304 failed to load

KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section

KERN: [idualwifi7260] (iwm) iwm_start_fw: failed -2147483639

Attachments (7)

Syslog-iwm3165.zip (23.4 KB ) - added by mrentropy 2 years ago.
Syslog contents of 32-bit build
syslog (194.3 KB ) - added by mrentropy 2 years ago.
Syslog contents of 32-bit build
syslog.2 (432.2 KB ) - added by mrentropy 18 months ago.
Syslog from hrev52730
syslog.3 (159.0 KB ) - added by cb88 18 months ago.
hrev52750 iwm broken for me, wifi was working on beta1
syslog.4 (171.0 KB ) - added by masaol 18 months ago.
hrev52792, x64
syslog-hrev53001 (200.1 KB ) - added by mrentropy 16 months ago.
Syslog from hrev53001 by request
wlan.txt (1.9 KB ) - added by grexe 5 months ago.
latest idualwifi7260/0 syslog

Download all attachments as: .zip

Change History (37)

by mrentropy, 2 years ago

Attachment: Syslog-iwm3165.zip added

Syslog contents of 32-bit build

comment:1 by waddlesplash, 2 years ago

Component: Network & Internet/WirelessDrivers/Network/idualwifi7260
Keywords: iwm driver wireless 3165 intel removed
Owner: changed from mmlr to waddlesplash

comment:2 by waddlesplash, 2 years ago

Please attach the syslog unzipped.

by mrentropy, 2 years ago

Attachment: syslog added

Syslog contents of 32-bit build

comment:3 by waddlesplash, 2 years ago

It appears the 3165 uses the "7265D" firmware: http://xref.plausible.coop/source/xref/haiku/src/add-ons/kernel/drivers/network/wlan/idualwifi7260/dev/iwm/if_iwm_7000.c#109

That's the exact same firmware my device uses, and it works, so I don't think that's the issue.

comment:4 by waddlesplash, 18 months ago

Please retest after hrev52722.

comment:5 by kim1963, 18 months ago

rev 52745

KERN: [idualwifi7260] (iwm) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)

KERN: add_memory_type_range(2067, 0xa2100000, 0x2000, 0)

KERN: set MTRRs to:

KERN: mtrr: 0: base: 0x8a000000, size: 0x2000000, type: 0

KERN: mtrr: 1: base: 0xa0000000, size: 0x20000000, type: 0

KERN: mtrr: 2: base: 0xc0000000, size: 0x40000000, type: 0

KERN: mtrr: 3: base: 0x90000000, size: 0x10000000, type: 1

KERN: allocate_io_interrupt_vectors: allocated 1 vectors starting from 18

KERN: msi_allocate_vectors: allocated 1 vectors starting from 18

KERN: [idualwifi7260] (iwm) bus_alloc_resource(1, [1], 0x0, 0xffffffff, 0x1,0x2)

KERN: msi enabled: 0x0081

KERN: [idualwifi7260] (iwm) iwm_read_firmware: unknown firmware section 512, abort

KERN: [idualwifi7260] (iwm) firmware parse error -2147483643, section type 512

KERN: [idualwifi7260] (iwm) iwm_read_firmware: failed -2147483643

KERN: [idualwifi7260] (iwm) Failed to start INIT ucode: -2147483643

comment:6 by kim1963, 18 months ago

https://git.haiku-os.org/haiku/tree/src/add-ons/kernel/drivers/network/wlan/idualwifi7260/glue.c#n29

HAIKU_FBSD_WLAN_DRIVER_GLUE(idualwifi7260, iwm, pci)

NO_HAIKU_FBSD_MII_DRIVER();

NO_HAIKU_REENABLE_INTERRUPTS();

HAIKU_DRIVER_REQUIREMENTS(FBSD_TASKQUEUES | FBSD_WLAN);

HAIKU_FIRMWARE_VERSION(1);

HAIKU_FIRMWARE_NAME_MAP(6) = {

{"iwm3160fw", "iwm-3160-17.ucode"},

{"iwm7260fw", "iwm-7260-17.ucode"},

{"iwm7265fw", "iwm-7265-17.ucode"},

{"iwm7265Dfw", "iwm-7265D-22.ucode"},

{"iwm8000Cfw", "iwm-8000C-22.ucode"},

{"iwm8265fw", "iwm-8265-22.ucode"},

};

comment:7 by mrentropy, 18 months ago

Tried with 64-bit nightly hrev52730, with no success. Adding syslog from this rev.

by mrentropy, 18 months ago

Attachment: syslog.2 added

Syslog from hrev52730

by cb88, 18 months ago

Attachment: syslog.3 added

hrev52750 iwm broken for me, wifi was working on beta1

comment:8 by waddlesplash, 18 months ago

See my comment in the other ticket: the "unknown firmware chunk 512" affects FreeBSD too, it's a 32-bit specific bug. 64-bit works.

comment:9 by cb88, 18 months ago

Not sure what othe ticket you are refering to. I'm updating my other PC with realtek at the moment so I'll update there shortly. Odd that this occurs now and didn't before though I guess they don't test on 32bit that much.

comment:10 by waddlesplash, 18 months ago

Resolution: fixed
Status: newclosed

comment:11 by waddlesplash, 18 months ago

For those with "could not load the [0] uCode section", retest after hrev52792.

comment:12 by masaol, 18 months ago

I've tried the latest commit, the problem still exists

KERN: pci_reserve_device(3, 0, 0, idualwifi7260)
KERN: [idualwifi7260] (iwm) bus_alloc_resource(3, [16], 0x0, 0xffffffffffffffff, 0x1,0x2)
KERN: [idualwifi7260] (iwm) bus_alloc_resource(1, [1], 0x0, 0xffffffffffffffff, 0x1,0x2)
KERN: [idualwifi7260] (iwm) fw chunk addr 0x800000 len 81920 failed to load
KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section
KERN: [idualwifi7260] (iwm) iwm_start_fw: failed -2147483639
KERN: [idualwifi7260] (iwm) Failed to start INIT ucode: -2147483639
KERN: pci_unreserve_device(3, 0, 0, idualwifi7260)
Last edited 18 months ago by korli (previous) (diff)

by masaol, 18 months ago

Attachment: syslog.4 added

hrev52792, x64

comment:13 by masaol, 18 months ago

Resolution: fixed
Status: closedreopened

comment:14 by cb88, 18 months ago

It should probably be noted that on my Lenovo laptops they only load wifi from a fresh boot, regardless of the OS. Often enough a warm boot results in the wifi chip not coming up.

comment:15 by waddlesplash, 18 months ago

Yes, I have the same issue, but I get a different error in that case (the ucode loads successfully but then commands time out.)

comment:16 by waddlesplash, 17 months ago

So, I got access to some 3165 hardware, and it works fine. The RTL81xx ethernet chipset in this device also works. So I don't know what's going on here :/

by mrentropy, 16 months ago

Attachment: syslog-hrev53001 added

Syslog from hrev53001 by request

comment:17 by luroh, 15 months ago

Summary: Intel iwm driver not loading for idualwifi7260[8086:3165] Intel iwm driver not loading for idualwifi7260

comment:18 by waddlesplash, 14 months ago

Please retest after hrev53174.

comment:19 by waddlesplash, 9 months ago

Blocking: 15388 added

comment:20 by diver, 9 months ago

Same issue here in hrev53561 x86_64:

grep idualwifi7260 /Haiku/system/var/log/syslog

KERN: pci_reserve_device(1, 0, 0, idualwifi7260)
KERN: [idualwifi7260] (iwm) bus_alloc_resource(3, [16], 0x0, 0xffffffffffffffff, 0x1,0x2)
KERN: [idualwifi7260] (iwm) bus_alloc_resource(1, [1], 0x0, 0xffffffffffffffff, 0x1,0x2)
KERN: [idualwifi7260] (iwm) fw chunk addr 0x404000 len 712 failed to load
KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section
KERN: [idualwifi7260] (iwm) iwm_start_fw: failed -2147483639
KERN: [idualwifi7260] (iwm) Failed to start INIT ucode: -2147483639

comment:21 by waddlesplash, 5 months ago

Blocking: 15724 added

comment:22 by waddlesplash, 5 months ago

Appears some newer hardware is affected too; upstream FreeBSD bug: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243992

comment:23 by grexe, 5 months ago

still occurs with latest hrev53889

by grexe, 5 months ago

Attachment: wlan.txt added

latest idualwifi7260/0 syslog

comment:24 by grexe, 5 months ago

in my case, I see no fw error, but the driver silently disconnects (see latest syslog attachment).

comment:25 by waddlesplash, 5 months ago

Uh ... this is a completely separate problem, which implies that firmware startup worked. This is also a completely different log from the one you posted on your other ticket, which was indeed a duplicate of this one. Please open a new ticket.

comment:26 by grexe, 5 months ago

woah this is bogus - it works now! :-D

I got it to work after a cold start, where my laptop takes quite a while to POST in EFI mode, before even showing the boot menu. When I wait patiently and start Haiku this way, everything is fine (have to reproduce and check). When booting into Haiku after using Linux (Manjaro/Arch Linux 5.55 X86-64), WLAN stops working...

Will do some more triaging and then file a new issue.

comment:27 by izaki, 3 months ago

I have an Intel 8265, running on hrev54051, x64, UEFI.

I am getting the same errors:

KERN: [idualwifi7260] (iwm) fw chunk addr 0x404000 len 712 failed to load
KERN: [idualwifi7260] (iwm) iwm_pcie_load_section: Could not load the [0] uCode section

I've seen the same bug is reported on FreeBSD (thanks for the link). I can try booting FreeBSD and seeing if the bug is resolved there.

Last edited 3 months ago by izaki (previous) (diff)

comment:28 by izaki, 3 months ago

Just tested booting FreeBSD 12.1 on the same machine, and while the firmware loads correctly, the card times out on any connection attempt.

I have not tried to boot Linux. I reckon the codebase is different, but if it works it would be interesting to see what are they doing.

comment:29 by waddlesplash, 3 months ago

The firmware loading or failing is permanent on some cards while on others it seems random. Cold boots often help. But other than that, I don't know.

comment:30 by grexe, 4 days ago

This seems to be related to starting in EFI or BIOS mode. I had wireless working consistently *every time* with Haiku in a MBR/BIOS install, but it consistently *broke* again after reinstalling Haiku in EFI/GPT mode.

In Linux, the same setup works perfectly with cold or warm boot, EFI and BIOS mode, so I don't think that's a cause for the issue.

Note: See TracTickets for help on using tickets.