Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#143 closed bug (fixed)

"jam install-haiku" adds suspicious links on my boot-drive

Reported by: genki@… Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Building Haiku with "jam install-haiku" adds at least three symlinks on my bootdrive.

In /boot/beos/apps, /boot/home and /boot/beos/preferences three symlinks are created that point to their respective parent directories.

It seems the symlinks are created during the "Populating image" process.

Attachments (1)

haiku.image-copy-files (78.2 KB) - added by genki@… 13 years ago.
hakiu.image-copy-files

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by bonefish

I just tried with revision 16344 and I couldn't reproduce this problem on my system.What names have the symlinks?What value has your HAIKU_INSTALL_DIR variable?Could you please comment out the RmTemps invocation in build/jam/HaikuImage for $(HAIKU_IMAGE_COPY_FILES_SCRIPT) (should be line 295). This should leave a file named "haiku.image-copy-files" in your generated/ directory after you have re-run "jam install-haiku". Among other things it contains all symlink creation commands during the installation process ("$ln -sf ..."). It would be nice, if you could send me the file (or have a look yourself, whether something looks suspicious). Thanks.

Changed 13 years ago by genki@…

Attachment: haiku.image-copy-files added

hakiu.image-copy-files

comment:2 Changed 13 years ago by bonefish

Apparently the ln that comes with R5 is buggy and always assumes switch "-n", while your ln doesn't. I added the switch in revision 16354. This should fix the problem.

comment:3 Changed 13 years ago by bonefish

Resolution: fixed

comment:4 Changed 13 years ago by bonefish

Status: newclosed
Note: See TracTickets for help on using tickets.