Opened 2 years ago

Closed 4 months ago

Last modified 3 months ago

#14306 closed bug (fixed)

Wrong drawing mode/or really ugly shadow in Deskbar application path.

Reported by: konrad Owned by: jscipione
Priority: normal Milestone: R1/beta2
Component: Applications/Deskbar Version: R1/Development
Keywords: drawing mode Cc:
Blocked By: Blocking:
Platform: All

Description

I really hate it when a developer comes with a suggestion for a fix, but here is my take:

  • Its probably using B_OP_COPY when it should be something else (B_OVER_OVER)?
  • Or its drawn twice with a shadow that looks uncrisp.

Attachments (2)

Skärmavbild 2018-07-28 kl. 10.13.16.png (109.2 KB ) - added by konrad 2 years ago.
Screenshot of deskbar
tracker.png (71.5 KB ) - added by konrad 2 years ago.
Tracker has the same bug.

Download all attachments as: .zip

Change History (9)

by konrad, 2 years ago

Screenshot of deskbar

comment:1 by konrad, 2 years ago

patch: 01

comment:2 by jscipione, 2 years ago

I'm afraid I don't know exactly what the bug you are reporting is. Are you talking about the shadow inside the text in the window menu item? It almost looks like the low color is not set right when drawing the string.

by konrad, 2 years ago

Attachment: tracker.png added

Tracker has the same bug.

comment:3 by konrad, 2 years ago

Yes, its probably the low color or the drawing mode.

comment:4 by pulkomandy, 2 years ago

patch: 10

comment:5 by jscipione, 8 months ago

I'm pretty sure this got fixed in hrev48817 specifically 5e625ead65c3 when the WindowMenuItem LowColor got set. I can no longer reproduce the issue.

comment:6 by diver, 4 months ago

Resolution: fixed
Status: newclosed

Can't reproduce either. Closing.

comment:7 by nielx, 3 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.