Opened 2 years ago

Closed 6 months ago

Last modified 4 months ago

#14336 closed bug (fixed)

TextSearch won't accept "--with-..." as search terms

Reported by: KapiX Owned by: phoudoin
Priority: normal Milestone: R1/beta2
Component: Applications/TextSearch Version: R1/Development
Keywords: Cc:
Blocked By: #15650 Blocking:
Platform: All

Description

It seems it's passing the term to grep unescaped, and grep fails with "unrecognized argument".

Change History (7)

comment:1 by phoudoin, 2 years ago

with Regular Expression enabled of not? A quick check show that grep -F "--with-..." wortks, but grep "--with-..." I guess when Regular Expression is enabled, the -e option should be explicitly passed then, as `grep -e "--with-..." works as expected

https://github.com/haiku/haiku/blob/master/src/apps/text_search/Grepper.cpp#L272

argv[argc++] = fRegularExpression ? "-e" : "-F";

Version 0, edited 2 years ago by phoudoin (next)

comment:2 by KapiX, 2 years ago

It doesn't work in both cases. Exact term: --with-theme in libreoffice's source directory.

comment:3 by phoudoin, 6 months ago

I guess the root cause was fixed in #15650. Could you check again?

comment:4 by phoudoin, 6 months ago

Blocked By: 15650 added

comment:5 by phoudoin, 6 months ago

Resolution: fixed
Status: newclosed

Closing, as I really believe this issue is a duplicate of #15650, which is fixed in hrev53758. Please re-open if the issue persists.

Last edited 6 months ago by phoudoin (previous) (diff)

comment:6 by KapiX, 6 months ago

Yes, it works now, thanks :)

comment:7 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.