Opened 2 years ago

Closed 22 months ago

Last modified 4 months ago

#14385 closed bug (fixed)

WebPositive webkit 1.6.6 crash on Yahoo News

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description (last modified by pulkomandy)

hrev52254 x86_64

HaikuWebKit 1.6.6

WebPositive crashes without warning on Yahoo News site. Syslog shows this:

KERN: 1125: DEBUGGER: getNumAvailable() == 0
KERN: debug_server: Thread 1125 entered the debugger: Debugger call: `getNumAvailable() == 0'
KERN: debug_server: Failed to prepare debugger handover: Bad port ID
KERN: debug_server: Killing team 1125 (/boot/system/apps/WebPositive)

Attachments (6)

WebPositive_Yahoo.txt (40.9 KB ) - added by vidrep 2 years ago.
libroot_debug.txt (980 bytes ) - added by vidrep 2 years ago.
WebPositive-1114-debug-23-08-2018-23-20-58.report (32.7 KB ) - added by vidrep 2 years ago.
libroot_debug_2.txt (2.8 KB ) - added by vidrep 2 years ago.
WebPositive-1605-debug-23-08-2018-23-26-19.report (53.4 KB ) - added by vidrep 2 years ago.
syslog_webpositive.txt (4.5 KB ) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (15)

by vidrep, 2 years ago

Attachment: WebPositive_Yahoo.txt added

comment:1 by vidrep, 2 years ago

Terminal log of session attached

comment:2 by pulkomandy, 2 years ago

Description: modified (diff)

comment:3 by pulkomandy, 2 years ago

Apparently there is an heap corruption. Can you reproduce with libroot_debug?

comment:4 by vidrep, 2 years ago

Attached are libroot_debug and a debugger report.

by vidrep, 2 years ago

Attachment: libroot_debug.txt added

comment:5 by vidrep, 2 years ago

I have attached a second set with a little more info.

by vidrep, 2 years ago

Attachment: libroot_debug_2.txt added

by vidrep, 2 years ago

Attachment: syslog_webpositive.txt added

comment:6 by pulkomandy, 2 years ago

This will be fixed in haikuwebkit 1.6.7. There was a leak of BBitmaps/BViews and eventually we would run out of ports.

comment:7 by vidrep, 22 months ago

This is working well since webkit 1.6.7 and is still the case with webkit --rebased build. Closing as fixed.

comment:8 by vidrep, 22 months ago

Resolution: fixed
Status: newclosed

comment:9 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.