Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#14387 closed bug (invalid)

Vision doesn't start anymore

Reported by: thaflo Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Vision, could not resolve symbol Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

After a pkgman update (21. August) Vision doesn't start anymore:

~> /boot/system/apps/Vision/Vision 
runtime_loader: /boot/system/apps/Vision/Vision: Could not resolve symbol 'Format__C14BMessageFormatR7BStringx'
resolve symbol "Format__C14BMessageFormatR7BStringx" returned: -2147478780
runtime_loader: /boot/system/apps/Vision/Vision: Troubles relocating: Symbol not found
~> 

Attachments (1)

Bitmap Clip (7.2 KB ) - added by thaflo 16 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 by waddlesplash, 16 months ago

Resolution: invalid
Status: newclosed

Problems with Vision are a HaikuPorts issue, and this one should have been solved already I think.

comment:2 by thaflo, 16 months ago

I tried to uninstall and reinstall via HaikuDepot. Still same problem.

in reply to:  2 comment:3 by Janus, 16 months ago

Replying to thaflo:

I tried to uninstall and reinstall via HaikuDepot. Still same problem.

Which version do you see in HaikuDepot when you select Vision?

comment:4 by humdinger, 16 months ago

Also, try to refresh the repos in HaikuDepot's tools menu.

comment:5 by thaflo, 16 months ago

Version 0.10.1-1 i update the repos already

comment:6 by humdinger, 16 months ago

If you actually deleted the old Vision hpkg and your repository is set to https://eu.hpkg.haiku-os.org/haikuports/master/repository/x86_gcc2/current , I'm out of ideas...

comment:7 by Janus, 16 months ago

You can always build the application from the repository:

clone https://github.com/HaikuArchives/Vision.git
cd Vision/src
make

you will find the application in

Vision/dist

comment:8 by thaflo, 16 months ago

thanks humdinger, I had set the another repo in the properties. I uninstalled and installed it again and it works now. thanks all for your help

comment:9 by humdinger, 16 months ago

Great! The repo URL changed quite a while back. If you haven't clean installed for some time and haven't updated the URL manually, you were still pointing to the out-of-date repo. Nightlies have the current URL set by default, of course. Happy Visioning.

by thaflo, 16 months ago

Attachment: Bitmap Clip added

comment:10 by thaflo, 16 months ago

Hello! I installed a Haiku image from 27. August Today I updated via Software Updater ) -- rev now 52273 Now Vision doesn't start anymore: missing symbol )see attachment= I didn't change anything on the system since installation Vision version 0.10.2-1 I deinstalled Vision from HaikuDepot and reinstalled it, now Vision starts

Last edited 16 months ago by thaflo (previous) (diff)

comment:11 by diver, 16 months ago

Vision was fixed in 0.10.2-2.

Note: See TracTickets for help on using tickets.