#14388 closed bug (duplicate)

Playing an audio CD does not work properly

Reported by: thaflo Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #13092 Blocking:
Has a Patch: no Platform: All

Description

Hello! I tried now a lot of Audio CDs on Haiku. The sound sounds broken, it does not play the files clean. I run Haiku native on a Acer Travelmate 2410 with additional RAM.. Internet-Streaming sounds very good. Terminal says not much: (is that frame count okay?)

~/Desktop> MediaPlayer /Gotthard\ -\ Open/02\ Vision.wav 
open playlist item: 02 Vision.wav
_InitFromTrack(): keyframes: 1, frame count: 10807440
running without video node
AudioProducer::_FillNextBuffer() - supplier error -> silence
~/Desktop> 

Attachments (3)

Audio Clip (2.2 MB) - added by thaflo 11 months ago.
Audio example
screenshot2.png (43.6 KB) - added by thaflo 11 months ago.
About window
syslog (19.7 KB) - added by thaflo 11 months ago.
syslog

Change History (9)

Changed 11 months ago by thaflo

Attachment: Audio Clip added

Audio example

Changed 11 months ago by thaflo

Attachment: screenshot2.png added

About window

comment:1 Changed 11 months ago by thaflo

Tried to play the Audio CD with Audacious -> the problem is even worse there

comment:2 Changed 11 months ago by waddlesplash

If streaming sounds good, this is probably a disk error in some way. Please attach a syslog.

comment:3 Changed 11 months ago by thaflo

Hello! I started a new installation of Haiku on another machine (64 bit this time) and I encounter exactly the same problem.

Changed 11 months ago by thaflo

Attachment: syslog added

syslog

comment:4 Changed 11 months ago by thaflo

syslog attached. file plays fine when .wav file copied from CD to Desktop. there must be read errors from the CD. How can i prove that?

comment:5 Changed 11 months ago by vidrep

Sounds like a duplicate ticket: https://dev.haiku-os.org/ticket/13092

comment:6 Changed 11 months ago by vidrep

Blocked By: 13092 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.