Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#14400 closed bug (fixed)

Booting with iprowifi220 results in kernel panic

Reported by: halamix2 Owned by: mmlr
Priority: normal Milestone: R1/beta2
Component: Network & Internet/Wireless Version: R1/Development
Keywords: intel 2200 Cc:
Blocked By: Blocking:
Platform: All

Description

I have laptop with 2915ABG Wi-fi card.

Tested on hrev52162, mentioned in #3180

I tried to "co" my way to desktop but I gave up after 20 continuations.

Attachments (3)

iprowifi2200_panic.log (4.9 KB ) - added by halamix2 4 years ago.
log file
iprowifi2200_panic_long.log (98.0 KB ) - added by halamix2 4 years ago.
Haiku_Kernel_Panic_iprowifi2200.jpg (1.4 MB ) - added by nuke9 4 years ago.

Download all attachments as: .zip

Change History (15)

by halamix2, 4 years ago

Attachment: iprowifi2200_panic.log added

log file

comment:1 by halamix2, 4 years ago

Also similar fixed issue where driverfailed gracefully (regression maybe?): #10891

comment:2 by waddlesplash, 4 years ago

Does the message change after 3 panics?

by halamix2, 4 years ago

Attachment: iprowifi2200_panic_long.log added

comment:3 by halamix2, 4 years ago

After 3 panics there is another panic message three times (thread 'daemon") and after that panics start oscillating between thread "daemon" and thread "a:392:x-vnd.Haiku-FirstBootProm" (with slight changes, first part of panic is the same in except first three)

Last edited 4 years ago by halamix2 (previous) (diff)

comment:4 by nuke9, 4 years ago

Same problem here...

I have an old 32bit Notebook with an Intel Pentium M Processor, and an Intel PRO/Wireless 2200BG card.

I've tried to install the latest Haiku OS (haiku-nightly-hrev52249-x86_gcc2_hybrid-anyboot), but as soon as the graphical boot-up finishes, and before the installer or desktop could start, I get a kernel panic that blames iprowifi2200. :-(

I've attached a "screenshot" made with my smartphone...

@halamix2: How did you get the message in a pure text log file? And how the long version?

comment:5 by halamix2, 4 years ago

I should mention that I have Pentium M as well (the laptop is Fujitsu Lifebook s7020) (and another error in intel_extreme but I hope it doesn't interfere with this one)

@Nuke: As for the log I connected through rs-232 cable and enabled serial debugging

Last edited 4 years ago by halamix2 (previous) (diff)

comment:6 by waddlesplash, 4 years ago

The other KDLs are probably timing issues caused by this one; for the beta branch at least the KDEBUG_LEVEL will be turned down a bit so these should be gone.

For now you can just blacklist the driver.

comment:7 by nuke9, 4 years ago

@halamix2: OK, thank you! :-) I'll give it a try, still having some RS-232 cables here... somewhere... ;-)

comment:8 by waddlesplash, 4 years ago

Resolution: fixed
Status: newclosed

This was fixed by changes to the compat layer.

comment:9 by godDLL, 4 years ago

I have to say, using hrev52527 my R50e ThinkPad gives me the same first for iprowifi2200, then ipro1000 too.

comment:10 by kuparikettu, 3 years ago

I have encountered this bug in nightly build hrev52815 on my Thinkpad X41.

comment:11 by waddlesplash, 3 years ago

It is almost certainly not the same bug, as the one described in this ticket was pretty definitively fixed, and the code in question hasn't changed since then. So, please open a new ticket and attach a picture.

comment:12 by nielx, 2 years ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.