Opened 13 months ago

Closed 7 months ago

#14406 closed bug (invalid)

VESA: Cannot select native resolution after monitor swap

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/VESA Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev52282

VESA driver working on Dell monitor for 2 years at native resolution of 1680x1050

Swapped to ViewSonic monitor. VESA working at native resolution of 1920x1080

Swapped back to Dell monitor. Now 1680x1050 resolution is longer available in Screen Preferences nor in available fail safe options in boot menu.

Change History (5)

comment:1 by waddlesplash, 13 months ago

Probably your graphics chipset adds the native resolution in the extra resolutions area. Try a cold reboot.

comment:2 by vidrep, 13 months ago

Installed a Radeon card, and now monitor is correctly identified as a Dell (1680x1050)

Pull Radeon card and boot with VESA driver, and now monitor incorrectly identified as a Viewsonic, and 1680x1050 not available.

How is VESA driver obtaining EDID info from the monitor? Something is broken.

comment:3 by vidrep, 13 months ago

Found a solution.

Currently I have two PC's connected to a shared monitor with a KVM switch. When I connect the PC's directly to the monitor, then the monitor is correctly identified as a Dell. I also found this post in the forum, which describes the same issue: https://discuss.haiku-os.org/t/force-specific-resolution-in-vesa-driver/3702

comment:4 by waddlesplash, 7 months ago

That is a pretty good indication that the problem is your KVM switch, not Haiku. I'd say we should close this as invalid; we don't really have any problems reading EDID.

comment:5 by waddlesplash, 7 months ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.