#14440 closed bug (fixed)

[Package Kit] can't create package with Zstd compression

Reported by: diver Owned by: korli
Priority: normal Milestone: Unscheduled
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

package recompress -z /system/packages/libreoffice-6.2.0.0~git-15-x86_64.hpkg libreoffice-6.2.0.0~git-15-x86_64.hpkg
Failed to compress chunk data: General system error

https://git.haiku-os.org/haiku/tree/src/kits/package/hpkg/PackageFileHeapWriter.cpp#n569

Change History (3)

comment:1 by waddlesplash, 14 months ago

Owner: changed from nobody to korli
Status: newassigned

comment:2 by korli, 14 months ago

Please try with hrev52308 or newer.

comment:3 by diver, 14 months ago

Resolution: fixed
Status: assignedclosed

Thanks! It's working now. LibreOffice package went down form 112MB to 107MB with best compression (9).

Note: See TracTickets for help on using tickets.