Opened 12 months ago

Closed 5 weeks ago

Last modified 3 weeks ago

#14451 closed bug (fixed)

Performance degradation after compiling large projects

Reported by: diver Owned by: nobody
Priority: high Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: Cc: ttcoder
Blocked By: Blocking: #14199
Has a Patch: no Platform: All

Description

x86_64 hrev52309 but it's been the case for a long time.

After compiling anything large like Qt or LibreOffice which stresses the OS a lot I observe a huge performance drop, apps starts longer, window redraw is slower too, etc. Reboot fixes it.

Attachments (1)

listarea.log (214.1 KB) - added by diver 6 months ago.

Download all attachments as: .zip

Change History (11)

Changed 6 months ago by diver

Attachment: listarea.log added

comment:1 Changed 6 months ago by diver

Attached listarea output after booting and compiling LibreOffice. I'm not sure what to look for there, tho.

comment:2 Changed 6 months ago by waddlesplash

It looks completely normal to me.

I wonder if it's the port heap which is somehow getting slowed down. Try running a full-system profile to see where the time is going.

comment:3 Changed 6 months ago by ttcoder

Cc: ttcoder added

comment:4 Changed 3 months ago by waddlesplash

So, I compiled GCC, and for the first 30 or so seconds after the build finished, performance was lower indeed in the ways you describe here (longer redraws, apps opening slower, etc.) However, after about a minute, things started improving, and after I ran a "sync" manually in Terminal, things were pretty much back to normal.

I have a VM paused here which is in this condition, but I really don't see much wrong with it.

There are quite a lot of "slab area"s in the kernel which looks odd, but that may just be the kernel allocator's caches, which it'll free when resources get low.

comment:5 Changed 3 months ago by waddlesplash

Created #15083 for the slabs issue. Otherwise I can't reproduce this ticket, my system seems back to normal after swap stabilized.

comment:6 Changed 6 weeks ago by diver

This is still reproducible in VMware Workstation in hrev53233 after booting and compiling LO. Opening new tab in Terminal takes one second, sync takes 3 seconds (after I let VM rest overnight).

comment:7 Changed 6 weeks ago by waddlesplash

Yes, but does "sync" take 3 seconds the second time you run it, or any subsequent time?

comment:8 Changed 6 weeks ago by diver

Nope, only the first time. However apps don't start launching any faster after that.

comment:9 Changed 5 weeks ago by diver

Resolution: fixed
Status: newclosed

Looks like I can't reproduce it anymore on hrev53259+3 running in VMware after compiling LibreOffice 6.3.

comment:10 Changed 3 weeks ago by waddlesplash

Blocking: 14199 added
Note: See TracTickets for help on using tickets.