#14450 closed bug (fixed)

[x86_64] hrev52309 - Terminal/shell missing libiconv

Reported by: ahwayakchih Owned by: jackburton
Priority: normal Milestone: R1/beta1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

After booting to desktop from Anyboot CD in VirtualBox, and trying to launch Terminal, i got message about missing libiconv.so.2 instead of bash (see attached screenshot).

It works fin on old install updated to hrev52309. Just not when booting to desktop from Anyboot CD.

Attachments (3)

VirtualBox_Haiku-hrev52309_05_09_2018_08_07_34.png (21.7 KB ) - added by ahwayakchih 14 months ago.
Terminal broken - missing libiconv.so.2
Haiku-hrev52309-live-cd-desktop.webm (2.6 MB ) - added by ahwayakchih 14 months ago.
Live CD desktop problem on hrev52309-x86_64
launch_daemon-153-debug-07-09-2018-12-30-21.report (10.9 KB ) - added by ahwayakchih 14 months ago.
Live CD desktop crash right after boot

Change History (14)

by ahwayakchih, 14 months ago

Terminal broken - missing libiconv.so.2

comment:1 by ahwayakchih, 14 months ago

hrev52302 seems to work ok.

can this be related to #14449?

comment:2 by diver, 14 months ago

Looks like Terminal can't start bash due to a missing lib. I wonder how it could happen as haiku package should (in)directly depend on libiconv. It shouldn't even boot, I think?

objdump -x /system/apps/Terminal | grep NEEDED
  NEEDED               libbe.so
  NEEDED               libtracker.so
  NEEDED               libtextencoding.so
  NEEDED               libstdc++.so.6
  NEEDED               libroot.so
  NEEDED               libgcc_s.so.1

objdump -x /bin/bash | grep NEEDED
  NEEDED               libreadline.so.7
  NEEDED               libhistory.so.7
  NEEDED               libncurses.so.6
  NEEDED               libintl.so.8
  NEEDED               libroot.so

objdump -x /system/lib/libintl.so.8 | grep NEEDED
  NEEDED               libiconv.so.2
  NEEDED               libroot.so

comment:3 by waddlesplash, 14 months ago

This sounds like something has a dependency misdeclared.

comment:4 by korli, 14 months ago

Keywords: libiconv.so.2 anyboot x86_64 removed
Platform: Allx86-64

Please add the list of installed packages.

by ahwayakchih, 14 months ago

Live CD desktop problem on hrev52309-x86_64

by ahwayakchih, 14 months ago

Live CD desktop crash right after boot

comment:5 by ahwayakchih, 14 months ago

korli: nothing added or removed. it was booted "live" from CD, so the list of packages is the same as the one on the CD. I can't list packages quickly because Terminal does not work. I can see libiconv-1.15.4-x86_64.hpkg in /boot/system/packages, but when i try to open it, HaikuDepot window shows up instead of package window. I can open other packages just fine, so i'm guessing something is wrong with libiconv package. I got lucky and got some crash on start, but it's not always the case (sometimes there is a crash, and sometimes it just boots to desktop like everything's fine, only things do not work like they should).

See attached video and crash report.

What's more, when i selected different language in installation window, before clicking on "boot to desktop" button, Terminal did not even show up libiconv error - it just remained "clean" instead (no text output at all).

Update: i mounted that CD into the working installation of Haiku and checked libiconv package:

/Haiku1/system/packages> package info libiconv-1.15-4-x86_64.hpkg 
Error: Failed to read package file "libiconv-1.15-4-x86_64.hpkg": Data read partially
/Haiku1/system/packages> package list libiconv-1.15-4-x86_64.hpkg 
_ReadBuffer(0x7fbc371b2540, 80) failed to read data: Data read partially

I also listed package files there:

/Haiku1/system/packages> ls -la
total 445366
drwxr-xr-x 1 user root      9216 Sep  4 14:33 .
drwxr-xr-x 1 user root      2048 Sep  4 14:33 ..
-rw-r--r-- 1 user root   1441549 Sep  4 14:33 autoconf-2.69-8-x86_64.hpkg
-rw-r--r-- 1 user root    782019 Sep  4 14:33 automake-1.15.1-1-x86_64.hpkg
-rw-r--r-- 1 user root   1941005 Sep  4 14:33 bash-4.4.023-1-x86_64.hpkg
-rw-r--r-- 1 user root    214481 Sep  4 14:33 bc-1.07.1-2-x86_64.hpkg
-rw-r--r-- 1 user root   3494054 Sep  4 14:33 binutils-2.28.1_2017_08_05-2-x86_64.hpkg
-rw-r--r-- 1 user root    598443 Sep  4 14:33 bison-3.0.5-1-x86_64.hpkg
-rw-r--r-- 1 user root     97690 Sep  4 14:33 bzip2-1.0.6-7-x86_64.hpkg
-rw-r--r-- 1 user root    124120 Sep  4 14:33 ca_root_certificates-2018_06_20-1-any.hpkg
-rw-r--r-- 1 user root   1700986 Sep  4 14:33 cdrtools-3.02~a09-1-x86_64.hpkg
-rw-r--r-- 1 user root   3924989 Sep  4 14:33 coreutils-8.29-1-x86_64.hpkg
-rw-r--r-- 1 user root    147509 Sep  4 14:33 ctags-5.8-5-x86_64.hpkg
-rw-r--r-- 1 user root    620368 Sep  4 14:33 curl_devel-7.61.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    416794 Sep  4 14:33 curl-7.61.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    257933 Sep  4 14:33 diffutils-3.6-1-x86_64.hpkg
-rw-r--r-- 1 user root    105759 Sep  4 14:33 expat-2.2.6-1-x86_64.hpkg
-rw-r--r-- 1 user root  10115805 Sep  4 14:33 ffmpeg-4.0.2-1-x86_64.hpkg
-rw-r--r-- 1 user root    941824 Sep  4 14:33 findutils-4.6.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    401041 Sep  4 14:33 flex-2.6.4-1-x86_64.hpkg
-rw-r--r-- 1 user root    455564 Sep  4 14:33 fontconfig-2.12.6-2-x86_64.hpkg
-rw-r--r-- 1 user root    416162 Sep  4 14:33 freetype-2.9-1-x86_64.hpkg
-rw-r--r-- 1 user root   1473295 Sep  4 14:33 gawk-4.2.0-1-x86_64.hpkg
-rw-r--r-- 1 user root   1537086 Sep  4 14:33 gcc_syslibs-7.3.0_2018_05_01-3-x86_64.hpkg
-rw-r--r-- 1 user root  45996148 Sep  4 14:33 gcc-7.3.0_2018_05_01-3-x86_64.hpkg
-rw-r--r-- 1 user root     64145 Sep  4 14:33 gettext_libintl-0.19.8.1-5-x86_64.hpkg
-rw-r--r-- 1 user root    211447 Sep  4 14:33 giflib-5.1.4-2-x86_64.hpkg
-rw-r--r-- 1 user root   1920551 Sep  4 14:33 git_daemon-2.16.4-1-x86_64.hpkg
-rw-r--r-- 1 user root  12830885 Sep  4 14:33 git-2.16.4-1-x86_64.hpkg
-rw-r--r-- 1 user root   1347552 Sep  4 14:33 glu_devel-9.0.0-7-x86_64.hpkg
-rw-r--r-- 1 user root    223028 Sep  4 14:33 glu-9.0.0-7-x86_64.hpkg
-rw-r--r-- 1 user root    413721 Sep  4 14:33 gmp-6.1.2-2-x86_64.hpkg
-rw-r--r-- 1 user root    781618 Sep  4 14:33 gnutls-3.6.3-1-x86_64.hpkg
-rw-r--r-- 1 user root    313822 Sep  4 14:33 grep-3.1-1-x86_64.hpkg
-rw-r--r-- 1 user root   7238498 Sep  4 14:33 groff-1.22.3-1-x86_64.hpkg
-rw-r--r-- 1 user root   5803166 Sep  4 14:33 gutenprint-5.2.14-1-x86_64.hpkg
-rw-r--r-- 1 user root     93404 Sep  4 14:33 gzip-1.8-2-x86_64.hpkg
-rw-r--r-- 1 user root   3942130 Sep  4 14:33 haiku_devel-r1~beta1_hrev52309-1-x86_64.hpkg
-rw-r--r-- 1 user root    315917 Sep  4 14:33 haiku_loader-r1~beta1_hrev52309-1-x86_64.hpkg
-rw-r--r-- 1 user root  44181128 Sep  4 14:33 haiku-r1~beta1_hrev52309-1-x86_64.hpkg
-rw-r--r-- 1 user root  21246975 Sep  4 14:33 haikuwebkit-1.6.6-2-x86_64.hpkg
-rw-r--r-- 1 user root  12604666 Sep  4 14:33 icu-57.1-3-x86_64.hpkg
-rw-r--r-- 1 user root    392760 Sep  4 14:33 ilmbase-2.2.1-1-x86_64.hpkg
-rw-r--r-- 1 user root     99631 Sep  4 14:33 jam-2.5_2012_10_12-5-x86_64.hpkg
-rw-r--r-- 1 user root    155554 Sep  4 14:33 jasper-2.0.14-1-x86_64.hpkg
-rw-r--r-- 1 user root    729351 Sep  4 14:33 jpeg_devel-9c-2-x86_64.hpkg
-rw-r--r-- 1 user root    133176 Sep  4 14:33 jpeg-9c-2-x86_64.hpkg
-rw-r--r-- 1 user root    666894 Sep  4 14:33 lcms-2.9-2-x86_64.hpkg
-rw-r--r-- 1 user root    123581 Sep  4 14:33 less-531-1-x86_64.hpkg
-rw-r--r-- 1 user root    104085 Sep  4 14:33 libedit-20180525_3.1-1-x86_64.hpkg
-rw-r--r-- 1 user root      6947 Sep  4 14:33 libexecinfo-1.1-4-x86_64.hpkg
-rw-r--r-- 1 user root     12677 Sep  4 14:33 libffi-3.2.1-4-x86_64.hpkg
-rw-r--r-- 1 user root    488632 Sep  4 14:33 libgcrypt-1.8.3-1-x86_64.hpkg
-rw-r--r-- 1 user root     86556 Sep  4 14:33 libgpg_error-1.32-1-x86_64.hpkg
-rw-r--r-- 1 user root     41827 Sep  4 14:33 libicns-0.8.1-7-x86_64.hpkg
-rw-r--r-- 1 user root         0 Sep  4 14:33 libiconv-1.15-4-x86_64.hpkg
-rw-r--r-- 1 user root    181948 Sep  4 14:33 libidn2-2.0.4-1-x86_64.hpkg
-rw-r--r-- 1 user root    561157 Sep  4 14:33 libmodplug-0.8.9.0-1-x86_64.hpkg
-rw-r--r-- 1 user root     26770 Sep  4 14:33 libogg-1.3.3-2-x86_64.hpkg
-rw-r--r-- 1 user root    140792 Sep  4 14:33 libpcap-1.8.1-3-x86_64.hpkg
-rw-r--r-- 1 user root    744423 Sep  4 14:33 libpcre-8.42-1-x86_64.hpkg
-rw-r--r-- 1 user root   1200640 Sep  4 14:33 libpcre2-10.30-1-x86_64.hpkg
-rw-r--r-- 1 user root    689322 Sep  4 14:33 libpng16_devel-1.6.35-1-x86_64.hpkg
-rw-r--r-- 1 user root    337499 Sep  4 14:33 libpng16-1.6.35-1-x86_64.hpkg
-rw-r--r-- 1 user root    208787 Sep  4 14:33 libsolv-0.3.0_haiku_2014_12_22-2-x86_64.hpkg
-rw-r--r-- 1 user root    131878 Sep  4 14:33 libtasn1-4.13-1-x86_64.hpkg
-rw-r--r-- 1 user root    396906 Sep  4 14:33 libtheora-1.1.1-7-x86_64.hpkg
-rw-r--r-- 1 user root    625519 Sep  4 14:33 libunistring-0.9.10-1-x86_64.hpkg
-rw-r--r-- 1 user root    281847 Sep  4 14:33 libvorbis-1.3.6-1-x86_64.hpkg
-rw-r--r-- 1 user root    927056 Sep  4 14:33 libvpx3-1.5.0-3-x86_64.hpkg
-rw-r--r-- 1 user root    479639 Sep  4 14:33 libwebp-1.0.0-1-x86_64.hpkg
-rw-r--r-- 1 user root   1990893 Sep  4 14:33 libxml2-2.9.7-2-x86_64.hpkg
-rw-r--r-- 1 user root    868773 Sep  4 14:33 libxslt-1.1.32-1-x86_64.hpkg
-rw-r--r-- 1 user root  22343736 Sep  4 14:33 llvm_libs-5.0.0-3-x86_64.hpkg
-rw-r--r-- 1 user root    246253 Sep  4 14:33 m4-1.4.18-3-x86_64.hpkg
-rw-r--r-- 1 user root    299751 Sep  4 14:33 make-4.1-3-x86_64.hpkg
-rw-r--r-- 1 user root      9625 Sep  4 14:33 makefile_engine-r1~beta1_hrev52309-1-any.hpkg
-rw-r--r-- 1 user root     75033 Sep  4 14:33 man-1.6g-6-x86_64.hpkg
-rw-r--r-- 1 user root    202560 Sep  4 14:33 mesa_devel-17.1.10-1-x86_64.hpkg
-rw-r--r-- 1 user root   2626256 Sep  4 14:33 mesa_swpipe-17.1.10-1-x86_64.hpkg
-rw-r--r-- 1 user root   2046035 Sep  4 14:33 mesa-17.1.10-1-x86_64.hpkg
-rw-r--r-- 1 user root     29286 Sep  4 14:33 mkdepend-1.7-5-x86_64.hpkg
-rw-r--r-- 1 user root     74188 Sep  4 14:33 mpc-1.1.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    665652 Sep  4 14:33 mpfr-3.1.6-2-x86_64.hpkg
-rw-r--r-- 1 user root    593818 Sep  4 14:33 nano-2.9.8-2-x86_64.hpkg
-rw-r--r-- 1 user root   1099834 Sep  4 14:33 nasm-2.12.01-4-x86_64.hpkg
-rw-r--r-- 1 user root   1170742 Sep  4 14:33 ncurses6-6.1-1-x86_64.hpkg
-rw-r--r-- 1 user root     13723 Sep  4 14:33 netcat-1.10-4-x86_64.hpkg
-rw-r--r-- 1 user root    761764 Sep  4 14:33 nettle-3.4-1-x86_64.hpkg
-rw-r--r-- 1 user root 123454659 Sep  4 14:33 noto_sans_cjk_jp-1.004-2-any.hpkg
-rw-r--r-- 1 user root  22646516 Sep  4 14:33 noto-20170920-3-any.hpkg
-rw-r--r-- 1 user root   5421434 Sep  4 14:33 openexr-2.2.1-2-x86_64.hpkg
-rw-r--r-- 1 user root    317494 Sep  4 14:33 openjpeg-2.3.0-1-x86_64.hpkg
-rw-r--r-- 1 user root   1906136 Sep  4 14:33 openssh-7.6p1-1-x86_64.hpkg
-rw-r--r-- 1 user root   8135664 Sep  4 14:33 openssl_devel-1.0.2p-1-x86_64.hpkg
-rw-r--r-- 1 user root   1667968 Sep  4 14:33 openssl-1.0.2p-1-x86_64.hpkg
-rw-r--r-- 1 user root    655574 Sep  4 14:33 p7zip-9.20.1-7-x86_64.hpkg
-rw-r--r-- 1 user root    279581 Sep  4 14:33 patch-2.7.5-2-x86_64.hpkg
-rw-r--r-- 1 user root   1234190 Sep  4 14:33 pe-2.4.5-8-x86_64.hpkg
-rw-r--r-- 1 user root  12779192 Sep  4 14:33 perl-5.26.1-2-x86_64.hpkg
-rw-r--r-- 1 user root    272744 Sep  4 14:33 pkgconfig-0.29.2-3-x86_64.hpkg
-rw-r--r-- 1 user root  26441258 Sep  4 14:33 python-2.7.14-2-x86_64.hpkg
-rw-r--r-- 1 user root    152578 Sep  4 14:33 readline-7.0.3-2-x86_64.hpkg
-rw-r--r-- 1 user root   1069762 Sep  4 14:33 scons-2.5.1-3-x86_64.hpkg
-rw-r--r-- 1 user root    125128 Sep  4 14:33 sed-4.4-3-x86_64.hpkg
-rw-r--r-- 1 user root    755412 Sep  4 14:33 sharutils-4.15.2-3-x86_64.hpkg
-rw-r--r-- 1 user root    614954 Sep  4 14:33 speex-1.2.0-3-x86_64.hpkg
-rw-r--r-- 1 user root   2642728 Sep  4 14:33 sqlite-3.24.0.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    474753 Sep  4 14:33 tar-1.29-3-x86_64.hpkg
-rw-r--r-- 1 user root    470961 Sep  4 14:33 tcpdump-4.9.2-1-x86_64.hpkg
-rw-r--r-- 1 user root   2758688 Sep  4 14:33 texinfo-6.5-1-x86_64.hpkg
-rw-r--r-- 1 user root    535039 Sep  4 14:33 tiff4-4.0.9-1-x86_64.hpkg
-rw-r--r-- 1 user root    175237 Sep  4 14:33 unzip-6.0-5-x86_64.hpkg
-rw-r--r-- 1 user root   1996199 Sep  4 14:33 vision-0.10.3-2-x86_64.hpkg
-rw-r--r-- 1 user root    415478 Sep  4 14:33 webpositive-r1~beta1_hrev52309-1-x86_64.hpkg
-rw-r--r-- 1 user root   1165437 Sep  4 14:33 wget-1.19.4-1-x86_64.hpkg
-rw-r--r-- 1 user root     16866 Sep  4 14:33 which-2.21-4-x86_64.hpkg
-rw-r--r-- 1 user root    203683 Sep  4 14:33 wpa_supplicant-2.7~devel.haiku.0-1-x86_64.hpkg
-rw-r--r-- 1 user root    214472 Sep  4 14:33 xz_utils-5.2.4-2-x86_64.hpkg
-rw-r--r-- 1 user root    334477 Sep  4 14:33 zip-3.0-4-x86_64.hpkg
-rw-r--r-- 1 user root     83716 Sep  4 14:33 zlib_devel-1.2.11-3-x86_64.hpkg
-rw-r--r-- 1 user root     48436 Sep  4 14:33 zlib-1.2.11-3-x86_64.hpkg
-rw-r--r-- 1 user root    369363 Sep  4 14:33 zstd-1.3.4-1-x86_64.hpkg

Looks like libiconv is empty there.

I was going to download latest nightly image (hrev52312) and check, but link is broken:

404 page not found

Link to hrev52309 does not work either. Looks like CDN is broken. I can see only "europe" links, and they are all pointing to 404: https://download.haiku-os.org/nightly-images/x86_64/ (raw images do not work either).

Last edited 14 months ago by ahwayakchih (previous) (diff)

comment:6 by korli, 14 months ago

I see that https://eu.hpkg.haiku-os.org/haikuports/master/build-packages is 404, so the build package repository is likely broken.

Last edited 14 months ago by korli (previous) (diff)

comment:7 by korli, 14 months ago

Component: Applications/TerminalSys-Admin
Owner: changed from jackburton to haiku-web

comment:8 by kallisti5, 14 months ago

Component: Sys-AdminApplications/Terminal
Owner: changed from haiku-web to jackburton
Status: newassigned

There was an outage this morning that our monitoring didn't catch. It should be resolved.

https://eu.hpkg.haiku-os.org/haikuports/master/build-packages/

(also note the trailing /, that's important if you want the index)

comment:9 by waddlesplash, 14 months ago

The iconv in the packages directory there looks fine:

libiconv-1.15-4-x86_64.hpkg                        08-Mar-2018 01:17              704559

So, not sure what's going on here. Can you try a more recent nightly? This may be a fluke.

comment:10 by ahwayakchih, 14 months ago

I can confirm that anyboot images seem to be fixed now. Both hrev52312 and hrev52316 work fine. Tested:

  • Boot to desktop and install from there
  • Install directly without booting to desktop

Must have been a problem with either CDN or build server(s).

hrev52309 is still broken, so maybe it should either be rebuilt/reuploaded or removed from the downloads list?

comment:11 by waddlesplash, 14 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.