Opened 12 years ago

Closed 11 years ago

#1446 closed bug (fixed)

[Tracker] problems with dragging many items

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku drops a message about mouse down in this situation: Press alt+f and enter. Now during several seconds tracker will try to find all files on partition. After that press alt+a to select them all and drag them. While roaster try to identify file types (i think this is why this delay in 10 seconds) click in anything (e.g. tab bar). This should mean that you ended dragging files, but several seconds later you will see that transparent selection will stick to your cursor, like you didn't click on tab seconds ago. BTW, If you press reset while dragging you will corrupt bfs. At least this will say serial output along with ide dma errors which will delay booting by 30 seconds. Should this be documented in another bug? I think i remember similar problems in other bug or two. Tested in vmware with hrev22147 under fedora 6.

Change History (6)

comment:1 by diver, 11 years ago

Can't reproduce it under VirtualBox. Probably fixed.

comment:2 by aldeck, 11 years ago

can't reproduce here hrev28405.

Diver, how many items did you try to drag? tried with ~250 items here.

To be sure, could you do some tests with a lot more items? thanks in advance, alex

comment:3 by diver, 11 years ago

I tried with 3500 items. I will retest it with vmware and on real hw.

comment:4 by anevilyak, 11 years ago

Can this one be closed diver? Have you had a chance to retest?

comment:5 by diver, 11 years ago

Can't reproduce in vmware, feel free to close this one :-)

comment:6 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.