Opened 9 months ago

Closed 5 months ago

#14500 closed bug (fixed)

rtl8188ce not showing in network preferences

Reported by: Anarchos Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/realtekwifi Version: R1/Development
Keywords: rtl8188ce Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This card shows up in the /dev tree but not in the network menu from Deskbar.

Attachments (1)

syslog (344.7 KB) - added by Anarchos 9 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 months ago by diver

syslog please.

comment:2 Changed 9 months ago by cb88

Mine does the same the 64bit EFI image on the forum waddlesplash posted actually worked fully with my card though (I had been testing only with 32bit hybrid where it didn't work).

There is also one patch in FreeBSD git that is probably applicable, it increases the firmware init timeout to 2 seconds, and this did have a noticable effect on my laptop when testing from 32bit gcc2 hybrid. The device would then show up in the menu and scan maybe once but didn't work after that.

UEFI vs UEFI+CSM may have some effect here not sure.

Changed 9 months ago by Anarchos

Attachment: syslog added

comment:3 Changed 9 months ago by diver

Component: Network & Internet/WirelessDrivers/Network/ralinkwifi
Owner: changed from mmlr to nobody

Does it show up if you issue ifconfig /dev/net/ralinkwifi/0 up?

comment:4 Changed 9 months ago by cb88

realtekwifi not ralinkwifi do note that the firmware timeout almost certainly needs to be increased it just wasn't in the freebsd 11.2 release etc... just right after.

Last edited 9 months ago by cb88 (previous) (diff)

comment:5 Changed 9 months ago by diver

Component: Drivers/Network/ralinkwifiDrivers/Network/realtekwifi

comment:6 in reply to:  3 Changed 9 months ago by Anarchos

Replying to diver:

Does it show up if you issue ifconfig /dev/net/ralinkwifi/0 up?

ifconfig /dev/net/realtekwifi/0 up --> card displayed in "Network Preferences", but it is unable to find the available networks.

comment:7 Changed 8 months ago by cb88

Could you try booting a recent 64bit image DD'd to a USB drive and disable legacy CSM support in your BIOS... this will mean you are booting on UEFI without the legacy CSM emulation. Note in my case just booting with UEFI enabled was not good enough.

I noticed when I did this on my x131e the realtekwifi worked and connected after this there must be something the UEFI and BIOS do differently that makes if work on one and fail on the other.

Last edited 8 months ago by cb88 (previous) (diff)

comment:8 Changed 5 months ago by waddlesplash

Please retest after hrev52744; the realtekwifi driver was updated to a version past FreeBSD 12 which includes a lot of changes to fix 8188EE devices.

comment:9 Changed 5 months ago by cb88

RTL8188CE seems to be working quite well now in on of my Lenovo x131e laptops... ran a few speedtests, and could get 19mbps in Web+ and between 25-35Mbps in Otter browser. Hasn't dropped out yet so I think it might be good nothing wierd in the logs either.

comment:10 Changed 5 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Nice.

Note: See TracTickets for help on using tickets.