Opened 12 years ago

Closed 10 years ago

#1452 closed bug (fixed)

Sudoku locks up when trying to solve puzzle I entered from a book

Reported by: scottmc Owned by: axeld
Priority: low Milestone: R1
Component: Applications/Sudoku Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm attaching 3 file of puzzles I entered from a book that I know contains "defective" puzzles. The symetric error files have a pair of square that could be interchanged giving the puzzle two possible solutions. The Haiku sudoku is able to "solve" it, assuming one of the two spots it seems. But it you put in the other option it solves it for the other solution. Not sure if this is a problem or not. I haven't checked around so see how this is handled, that is, is this even a valid puzzle or is the book i have just filled with defective puzzles. I'm betting that is the case. The last one is one I haven't finshed myself but I entered it into the program and clicked solved and it seems to have locked up, either that or it is taking an aweful long time to solve it. That one is labeled test36, since it was #36 in the book i had. I'll try putting in a few more puzzle I located in that book that I know are wrong, such as ones that were misprinted.. should be a good test to run the game through to verify that it's able to handle bad input correctly ;) Yeah we're here kicking the tires.

Attachments (3)

sudoku-symetric-error-test (129 bytes) - added by scottmc 12 years ago.
sudoku-symetric-error-test2 (129 bytes) - added by scottmc 12 years ago.
sudoku-test36 (129 bytes) - added by scottmc 12 years ago.

Download all attachments as: .zip

Change History (12)

Changed 12 years ago by scottmc

Attachment: sudoku-symetric-error-test added

Changed 12 years ago by scottmc

Attachment: sudoku-symetric-error-test2 added

Changed 12 years ago by scottmc

Attachment: sudoku-test36 added

comment:1 Changed 12 years ago by scottmc

Version being test on is hrev22149.

comment:2 Changed 12 years ago by marcusoverhagen

Component: - Audio & Video- Applications/Sudoku
Owner: changed from marcusoverhagen to axeld

comment:3 Changed 12 years ago by axeld

Priority: normallow

Thanks for testing! If a puzzle has more than one solution, Sudoku will just pick a random one of them.

And sudoku-test36 is solved here, too, it just takes a couple of seconds to do so. Haven't I mentioned that the solving mechanism is currently pretty stupid? :-) But as long as that is the case, I should probably detach the solving computation from the window thread, just like it's done when generating a Sudoku.

comment:4 Changed 12 years ago by scottmc

A couple other things to note, it'd be nice to have a "save/load current game" option, which would also save all the markups I've made so far. Also when I've already marked up and accidentally click the wrong button and it enters in a number I then lose the markups i made if i unclear the box. Be nice to have an undo, or at least have it go back and show the markups i had before clicking the wrong button.

This is the BEST computer Sudoku game I've tried so far. That's out of about 10 different ones I've tried. I like the input model, simple and works great, nice job on it so far.

I'll check it again with the test36 and see if it still locks up. I'll try finding a few more puzzles to use for future regression style tests.

comment:5 Changed 12 years ago by axeld

Loading and saving is indeed planned, even though it already preserves its state when you are closing it. Undo/Redo would be nice, too.

comment:6 Changed 11 years ago by scottmc

Does the new save/reload option recall the markups? Also any plans to add undo/redo? I'll have to try this out again.

comment:7 Changed 11 years ago by axeld

Yes I plan to do this. Anyway, this is not a message board, so any conversation hold here should be related to the bug in question (not just the app :-)). Just ask me directly, or on the list.

comment:8 Changed 11 years ago by scottmc

Looks like this has been updated to add the undo/redo and saving of markups and such. Axel you rock. This can be closed now I suppose.

comment:9 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.