Opened 13 years ago

Closed 17 months ago

Last modified 6 weeks ago

#1451 closed bug (no change required)

Right mouse click over Nick lister in Bowser: Setup doesn't work in Bowser 1.1.1

Reported by: ackcontrols Owned by: nobody
Priority: normal Milestone:
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

When running Bowser 1.1.1 (downloaded from BeBits), I cannot add a Nick by pressing the right mouse key. Works under BeOS R5, but not under Haiku. Hope this helps someone. When right mouse clicking, a menu should appear with the options Add, Remove, Load.

Change History (6)

comment:1 by mmadia, 10 years ago

Can you retest this on R1/Alpha 2 or even a nightly image?

comment:2 by siarzhuk, 8 years ago

The problem is that Bowser uses MessageFilter to handle menu and keyboard events in the list of nicks. That filter is created with following flags:

http://bowser.cvs.sourceforge.net/viewvc/bowser/Bowser/src/SetupWindow.cpp?revision=1.13&view=markup

1217	NickFilter::NickFilter (SetupView *sv)
1218	        : BMessageFilter (B_PROGRAMMED_DELIVERY, B_LOCAL_SOURCE),
1219	          view (sv)
1220	{
1221	}

And changing B_LOCAL_SOURCE to B_ANY_SOURCE restores function of context menu. Looks like Haiku has another meaning about B_LOCAL_SOURCE than BeOS had.

BeBook say about the 'source' parameter:

source Specifes whether the sender of the message must be local vis-a-vis this app (B_LOCAL_SOURCE), remote (B_REMOTE_SOURCE), or either (B_ANY_SOURCE). The default is B_ANY_SOURCE.

In my opinion messages issued by user's mouse click should be counted as remote ones, so this issue looks like BeOS error.

Do you have any opinions about this, gentlemen?

comment:3 by axeld, 8 years ago

I would agree with that - the only remaining question is if we want to be compatible or not (for example, we could force B_ANY_SOURCE for all applications linked for BeOS).

comment:4 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:5 by waddlesplash, 17 months ago

Resolution: no change required
Status: assignedclosed

Seeing as no other applications have been found which depended on this functionality in the last 11 years, and Bowser is of course open source and can/could be fixed, I think leaving the situation as-is is fine.

comment:6 by nielx, 6 weeks ago

Milestone: R1

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.