#14524 closed bug (duplicate)

Screen turns black after rocket icon lit on Haiku splash

Reported by: LeapingFrog Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: black screen at boot Cc:
Blocked By: #14276 Blocking:
Has a Patch: no Platform: x86

Description

Booting

    haiku-master-hrev52357-x86_gcc2_hybrid-anyboot

ends up in black screen after rocket icon on Haiku splash is lit.

The machine is small Laptop

    FM V-Biblio Loox U50X/V

from Fujitsu, 2007. CPU is A110. (This CPU evolved in Atom Processors.)

The symptom is the same for booting from USB and from HD. Mitigation by setting

   fail_safe_video_mode true

in

    ~/config/settings/kernel/drivers/kernel

works.

There are two graphic controllers.

device Display controller [3|80|0]
  vendor 8086: Intel Corporation
  device 27a6: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 27a2: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

While the screen is black, I connected a projector to the 15pin output. The projector seemed to detect no signal. I admit conversion from 15pin to HDMI might harm the signal.

I attach syslogs

    syslog20180925a.txt   for a boot ending up with black screen
    syslog20180925b.txt   for a boot with fail-safe-vide-mode set after boot manager.

Attachments (2)

syslog20180925a.txt (135.8 KB) - added by LeapingFrog 10 months ago.
syslog20180925b.txt (125.1 KB) - added by LeapingFrog 10 months ago.

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by LeapingFrog

Attachment: syslog20180925a.txt added

Changed 10 months ago by LeapingFrog

Attachment: syslog20180925b.txt added

comment:1 Changed 10 months ago by diver

Component: - GeneralDrivers/Graphics/intel_extreme
Owner: changed from nobody to kallisti5

comment:2 Changed 10 months ago by diver

Probably a dupe of #14276.

comment:3 Changed 10 months ago by LeapingFrog

Yes, I detect similarity.

But I am testing something that might be specific to the model of PC.

I connected the machine to the projector and booted Haiku-OS. Then, I opened preferences-->screen. It does not detect the projector nor any second screen. The projector does not detect the signal either.

I will move to #14276 for issues related with the single Graphics controller "945".

If I find something specific to my model, I will come back to this ticket.

comment:4 Changed 10 months ago by LeapingFrog

I missed report one thing. I rebooted Winsows Vista right after the previous test and tried to setup multiscreen. It was successful and I can trace mouse pointer moving in the projector's screen.

It is just Haiku-OS failing to use the second screen.

If I can activate the driver for the second screen, I might more easily test graphics drivers by assigning different drivers for two different screens.

comment:5 Changed 10 months ago by diver

Blocked By: 14276 added
Resolution: duplicate
Status: newclosed

It's just Haiku, not Haiku-OS. Anyway multi monitor setup is not supported by intel_extreme yet or vesa.

Note: See TracTickets for help on using tickets.