Opened 5 months ago

Last modified 8 weeks ago

#14535 new bug

GLInfo doesn't display renderer information and crashes on exit.

Reported by: kallisti5 Owned by: kallisti5
Priority: high Milestone: Unscheduled
Component: Kits/OpenGL Kit/Software Pipe Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by kallisti5)

GLInfo doesn't display renderer information and crashes on exit. Likely due to recent mesa changes.

We *can* patch post-hrev1 via haikuports updates, however.

x86_64, r1beta1 rc1

Attachments (3)

GLInfo-1373-debug-07-10-2018-17-04-31.report (25.0 KB) - added by vidrep 4 months ago.
GLInfo_syslog.txt (1.5 KB) - added by vidrep 4 months ago.
mesa-17.1.10_haiku_hrev52695_cocobean.txt (5.6 KB) - added by cocobean 8 weeks ago.
Mesa 17.1.10 GLInfo output

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 months ago by kallisti5

Description: modified (diff)

comment:2 Changed 5 months ago by waddlesplash

Nope, it's done this since last year, not related to recent changes.

comment:3 Changed 5 months ago by kallisti5

"It should work" though. It just calls standard OpenGL API's. Nothing fancy or special.

comment:4 Changed 5 months ago by kallisti5

Version: R1/DevelopmentR1/beta1

comment:5 Changed 5 months ago by waddlesplash

Milestone: R1/beta1Unscheduled
Version: R1/beta1R1/Development

comment:6 Changed 5 months ago by luroh

Works and doesn't crash on exit with gcc2h.

comment:7 Changed 5 months ago by diver

I see renderer information in VMware Workstation 15 and don't in VMware Fusion 10.1.3. Crashes on quit with Alt+q.

comment:8 Changed 4 months ago by vidrep

Crashes on hrev52388 x86_64. Debug report attached.

Changed 4 months ago by vidrep

Attachment: GLInfo_syslog.txt added

comment:9 Changed 4 months ago by diver

This is a different bug, see #13192.

Changed 8 weeks ago by cocobean

Mesa 17.1.10 GLInfo output

comment:10 Changed 8 weeks ago by cocobean

@kallisti5 - I tested within the Haiku terminal with Mesa's glinfo and the output is OK (see attachment). Gallium context window handling seem OK - but think its the way the OpenGL setup/create screen is initialized for GLInfo GUI under Mesa 17.x.

Last edited 8 weeks ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.