Opened 22 months ago

Closed 4 months ago

#14629 closed bug (duplicate)

GUI: Window focus when closing active window in "stacking" mode

Reported by: msiism Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: Servers/app_server Version: R1/beta1
Keywords: GUI focus Cc:
Blocked By: #15755 Blocking:
Platform: All

Description

Whenever you close an active window in Haiku's GUI in "stacking"/default mode (meaning windows are neither tabbed ("stacked") nor tiled), all other windows on the screen stay unfocussed. I've tested this with several applications in different combinations, including Tracker, StyledEdit, Koder and Terminal.

I think this behavior should be changed in such a way that the window directly beneath the current active window is automatically focussed when the one above it is closed.

This would also be in line with how the UI behaves in stack & tile mode (the first of which should really be called tab or tabbing mode).

This issue appears to be related to #9595.

I'm using hrev52295+100.

Change History (5)

comment:1 by msiism, 22 months ago

I've just discovered one case where it works as expected and that is with the Downloads window of WebPositive. When I close it, WebPositive's main window gets focus automatically. Also, when I open a downloaded video file in MediaPlayer directly from the Downloads window, focus will jump back to it when I close the player.

comment:2 by diver, 22 months ago

Component: - GeneralServers/app_server
Owner: changed from nobody to axeld

comment:3 by diver, 22 months ago

Normally the previous window gets focus, which in your case can be Deskbar.

comment:4 by X512, 4 months ago

Duplicate of #15755.

comment:5 by waddlesplash, 4 months ago

Blocked By: 15755 added
Resolution: duplicate
Status: newclosed

#15755 is more specific, so closing in favor of that, indeed.

Note: See TracTickets for help on using tickets.