Opened 9 years ago

Closed 20 months ago

#9595 closed bug (duplicate)

Tracker windows do not receive focus

Reported by: Kev Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #15755 Blocking: #6790
Platform: All

Description

On a blank workspace, open a Tracker window and then another program. Close the other program using Alt + W. The Tracker window should receive the focus, but it doesn't. hrev45413 gcc4hybrid.

From this discussion I wonder if instead of the desktop being avoided, all Tracker windows are being avoided, instead.

Change History (18)

comment:1 by diver, 9 years ago

Might be a dupe of #9423.

comment:2 by Kev, 9 years ago

I don't have "focus follows mouse" on though...does that make a difference?

comment:3 by Giova84, 9 years ago

I have found the same: eg. when i delete a file, the alert window steals the focus to Tracker. I don't have set "focus follows mouse".

in reply to:  3 comment:4 by Kev, 9 years ago

Replying to Giova84:

I have found the same: eg. when i delete a file, the alert window steals the focus to Tracker. I don't have set "focus follows mouse".

Do you mean then Tracker has focus instead of the alert window?

In my case I want Tracker to have the focus (so I can continue closing windows) but it doesn't--all the open windows have grey tabs, so I guess either the desktop-special-Tracker-window-that-has-no-tab or the Deskbar end up with the focus.

comment:5 by Giova84, 9 years ago

I mean that: Tracker loses focus when an alert window appear on the screen. When the alert window is closed, Tracker is without focus on it. And in anyway i have also found the same issue which you have found.

Last edited 9 years ago by Giova84 (previous) (diff)

comment:6 by Kev, 9 years ago

I just also experienced this with StyledEdit windows, if I interact with the Desktop in between interacting with the StyledEdit windows, I can't then just Alt+W a bunch of times to close them because the focus ends up on the Desktop at some point.

comment:7 by diver, 9 years ago

Can't reproduce. Might be fixed in hrev45665?

comment:8 by bonefish, 9 years ago

Resolution: fixed
Status: newclosed

Indeed, that's what hrev45665 fixes.

comment:9 by Kev, 8 years ago

comment:6 is still true as of hrev46756 . Was it unrelated to the original report and I should open a new ticket? Or did this regress? Steps to reproduce:

1) boot 2) open two StyledEdit windows 3) click the desktop 4) click a StyledEdit window 5) hit Alt+W 6) the desktop now has the focus instead of the other StyledEdit window

comment:10 by Kev, 8 years ago

Resolution: fixed
Status: closedreopened

comment:11 by axeld, 5 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:12 by miqlas, 3 years ago

Still exist on x86_64 current Haiku. (hrev 52020) Focus follows the mouse also deactivated.

Testcase: open 1 Tracker window, selct a file, press Alt-I for informations. Close the info window with Alt-W. Focus is on Deskbar instead of the last Tracker window.

comment:13 by miqlas, 3 years ago

According my tests, if Deskbar have "Always on Top" enabled, it steals the focus.

comment:14 by miqlas, 3 years ago

Deactivating Deskbar "Always on Top" setting soves the problem. But it is a workaround, ofc.

comment:15 by waddlesplash, 3 years ago

Blocking: 6790 added

comment:16 by X512, 20 months ago

Duplicate of #15755.

comment:18 by X512, 20 months ago

Issue is not fixed, resolution should be set to duplicate and/or blocking should be set.

comment:19 by diver, 20 months ago

Blocked By: 15755 added
Platform: x86All
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.