Opened 12 years ago

Closed 12 years ago

#1464 closed bug (fixed)

Broken filesystem

Reported by: kaliber Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm glad that bug #1363 is fixed, but since that time I have a problem with filesystem. After untaring a few files I got an error (no KDL).

bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659776 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659776 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659778 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659778 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659778 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659778 corrupt!
bfs: InitCheck:272: Bad data
bfs: bfs_lookup:476: Bad data
bfs: B+tree header size 7236837475348997742 doesn't fit file size 2048!
bfs: SetTo:461: Bad data
bfs: inode tree at block 659778 corrupt!

Change History (2)

comment:1 by kaliber, 12 years ago

I think this ticket can be closed as fixed. Seems that it was caused by some of VM bug(s). I cannot reproduce this again with current version of Haiku.

comment:2 by korli, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.