Opened 10 months ago

Closed 7 months ago

Last modified 7 months ago

#14756 closed bug (duplicate)

XHCI / usb_disk: transfers stall

Reported by: Berusik Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: #13792 Blocking:
Has a Patch: no Platform: x86-64

Description


Attachments (2)

IMG_20181212_174738.jpg (3.0 MB ) - added by Berusik 10 months ago.
photo_2019-01-16_23-13-22.jpg (65.3 KB ) - added by BeRUS 8 months ago.

Change History (16)

by Berusik, 10 months ago

Attachment: IMG_20181212_174738.jpg added

comment:1 by waddlesplash, 10 months ago

Please run the "syslog" command at the prompt and take a screenshot of the last page of output.

comment:2 by Berusik, 10 months ago

After this message, i reboot pc, and give new message: https://ibb.co/H2XvVWt Insert thiss message syslog page?

comment:4 by waddlesplash, 10 months ago

Component: - GeneralDrivers/USB/XHCI
Summary: Kernel panic on boot usbXHCI / usb_disk: transfers stall and then _kern_read segfaults

I know I've seen this before, but I can't seem to locate the ticket this is a duplicate of.

comment:5 by waddlesplash, 10 months ago

It seems descriptor->ops being NULL is a valid state to be in: http://xref.plausible.coop/source/xref/haiku/src/system/kernel/fs/fd.cpp#226

I guess packagefs is attempting a read on a closed fd, which is odd. At any rate _kern_read should be able to tolerate that and return B_BAD_VALUE like it does elsewhere.

comment:6 by waddlesplash, 9 months ago

KDL fixed in hrev52646; the system will probably either stall or hit another KDL on boot. Please try with a nightly after that when you can.

comment:7 by Berusik, 9 months ago

Haiku booted, and deskbar, and tracker not worked, work mouse cursor drag, in hrev52646

Last edited 9 months ago by Berusik (previous) (diff)

comment:8 by waddlesplash, 9 months ago

Summary: XHCI / usb_disk: transfers stall and then _kern_read segfaultsXHCI / usb_disk: transfers stall

OK, that makes sense; disk I/O is failing in strange ways.

comment:9 by Berusik, 9 months ago

Can it fix?

comment:10 by Berusik, 9 months ago

I tried to run without hard drives, tried to record haiku on another flash, it’s still the same

comment:11 by waddlesplash, 9 months ago

Yes, I would expect so, the problem is in our XHCI bus driver so probably all USB ports will be affected.

by BeRUS, 8 months ago

comment:12 by BeRUS, 8 months ago

52761 i lock in boot xhci driver and keep this new attach

comment:13 by waddlesplash, 7 months ago

Blocked By: 13792 added
Resolution: duplicate
Status: newclosed

comment:14 by waddlesplash, 7 months ago

As per comment on the main ticket: it seems this is now fixed.

Note: See TracTickets for help on using tickets.