Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1478 closed bug (invalid)

Unreadable output from Haiku to SerialConnect

Reported by: meanwhile Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Can't offer a clue about a non-working Haiku install by using SerialConnect: the output Haiku gives is unreadable. SerialConnect was set up on another BeOS machine and connected via null modem cable directly (from serialport to serialport). Settings were according to the BeOS Bible, as follows: Parity: none Databits: 8 Stopbits: 1 Baud Rate: 19200 Flow Control: RTS/CTS (also tried this with 'none'...same result)

Attachments (1)

SerialConnect.jpg (385.0 KB ) - added by meanwhile 12 years ago.
(Sorry, couldn't use another method than a camera "screenshot")

Download all attachments as: .zip

Change History (4)

by meanwhile, 12 years ago

Attachment: SerialConnect.jpg added

(Sorry, couldn't use another method than a camera "screenshot")

comment:1 by umccullough, 12 years ago

IIRC, you must use 57600 rate by default.

comment:2 by bonefish, 12 years ago

Resolution: invalid
Status: newclosed

The baud rate is 115200, no flow control, no parity, 8 data bits, 1 stop bit.

comment:3 by umccullough, 12 years ago

Of course - I'm not sure what I was thinking :P

Clearly, it's been a while since I've run serial debug (fortunately I rarely have to!)

Note: See TracTickets for help on using tickets.