Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1479 closed bug (fixed)

Laptops fail to shutdown or restart properly

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1/alpha1
Component: Drivers/Keyboard/PS2 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I checked in BeOS Max and it shuts down fine there, but in Haiku it freezes on the shutdown or the restart. Attached to ticket #1169 is the listdev from this laptop in case that is any help. http://dev.haiku-os.org/attachment/ticket/1169/Thinkpad-570E-listdev.txt

Attachments (2)

Thinkpad-570-no-shutdown.jpg (23.6 KB ) - added by scottmc 12 years ago.
ThinkPad570E-with-APM-true-Serial-Debug.txt (42.7 KB ) - added by scottmc 12 years ago.
Serial Debug output from the Thinkpad 570E with the apm enable in the kernel settings file.

Download all attachments as: .zip

Change History (14)

by scottmc, 12 years ago

comment:1 by jackburton, 12 years ago

Is Apm enabled ? (it's disabled by default)

comment:2 by scottmc, 12 years ago

How do you enable it? I'll give it a shot if you can guide me.

in reply to:  2 ; comment:3 by jackburton, 12 years ago

Replying to scottmc:

How do you enable it? I'll give it a shot if you can guide me.

Check the kernel settings file /home/config/settings/kernel/drivers/kernel. there's a commented line:

#apm true

Uncomment it. Reboot. Apm should be enabled.

by scottmc, 12 years ago

Serial Debug output from the Thinkpad 570E with the apm enable in the kernel settings file.

in reply to:  3 comment:4 by scottmc, 12 years ago

Ok, tried that and it still fails. I finally got a null modem cable hooked up and included the serial debug info from this. Lines 941 and on are from the shutdown routine. Not sure if that helps any. Any other ideas to get more details to help debug this?

Replying to jackburton:

Replying to scottmc:

How do you enable it? I'll give it a shot if you can guide me.

Check the kernel settings file /home/config/settings/kernel/drivers/kernel. there's a commented line:

#apm true

Uncomment it. Reboot. Apm should be enabled.

comment:5 by scottmc, 12 years ago

Ok, this seems to have been caused by something that has changed in the last 2 weeks as it's affecting my eMachine M6805 laptop the same way. It used to shut down or restart just fine on older Haiku builds.

comment:6 by scottmc, 12 years ago

Summary: Thinkpad 570 fails to shutdownLaptops fail to shutdown or restart properly

in reply to:  5 comment:7 by scottmc, 12 years ago

Replying to scottmc:

Ok, this seems to have been caused by something that has changed in the last 2 weeks as it's affecting my eMachine M6805 laptop the same way. It used to shut down or restart just fine on older Haiku builds.

Or not. Seems to be shutting down on the M6805 again now. Not sure what's going on. I'll test the next few builds and see if maybe my install got corrupted along the way.

comment:8 by axeld, 12 years ago

Are there any problems left after hrev22617?

comment:9 by scottmc, 12 years ago

I tried it last night using hrev22629 and now the Thinkpad 570E won't even boot up all the wat into Haiku. It gets stuck on the black screen with the Haiku logo. I tried enabling onscreen debug output but it doesn't show up either. I tried rolling back to a Haiku image I had from Oct3rd and that one boots into Haiku just fine on this same PC. So I tried it again this morning with hrev22697 and got the same results as with hrev22629. Not what happened but something between Oct3rd and hrev22629 broke Haiku on this laptop. I can try hooking it up tomorrow to get serial debug output from it to help figure out where it's getting stuck. Also I did try disabling APM and ACPI in the kernel file on the hrev22629 build, but it still hung.

comment:10 by scottmc, 12 years ago

It looks like #1479 is partially fixed (might be completely fixed need to test more), that is when I try to shutdown now it will display a dialog box allowing my to click a button to reboot and it works. In hrev22597 it would just freeze up at that point. I have not yet played with the APM settings to see if it will auto shutoff. I will do more testing on this as I get time. I'm trying to work around #1587 right now.

comment:11 by axeld, 12 years ago

Component: SystemDrivers/Keyboard/PS2
Milestone: R1R1/alpha
Resolution: fixed
Status: newclosed

Okay, thanks for the update. Fixed in hrev22617.

comment:12 by scottmc, 12 years ago

The Thinkpad 570E is working again so I can now say that this was indeed fixed, as is still working fine in hrev23287

Note: See TracTickets for help on using tickets.