Opened 4 months ago

Closed 7 days ago

#14823 closed bug (duplicate)

Kernel crash when browsing from Guitar app - Haiku R1/Dev Haiku/béta1

Reported by: rose.kanari Owned by: korli
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Guitar, Git GUI Cc:
Blocked By: #14969 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Hello all,

It's my first ticket. I hope it will be understandable and in the right place.

I try to use Guitar application (third application in the haikudepot) but I have a kernel crash on Haiku R1/Dev & R1/beta1. (twice x64).

like use the browse action in application

PANIC: SNAP violation user—mapped address 0x00007fcbb4e2ee40 touched from kernel 0xffffffff8016b355
Welcome to Kernel Debugging Land...
Thread 1861 Guitar” running on CPU 1
stack trace for thread 1861 "Guitar"
kernel stack: 0xffffffff81db6000 to 0xffffffff81dbb000
user stack: 0x00007fcbb3e32000 to 0x00007fcbb4e32000
frame caller <image>:function + offset
0 ffffffff81dba698 (+ 24) ffffffff8014balc <kernel_x86_64> arch_debug_call_with_fault_handler + 0x16
1 ffffffff81dba6b0 (+ 80) ffffffff800acd58 <kernel_x86_64> debug_call_with_fault_handler + 0x68
2 ffffffff81dba700 (+ 96) ffffffff800ae701 <kernel_x86_64> kernel_debugger_loop(char const*, char const*, _va_list_tags, int) + Oxf 1
3 ffffffff81dba760 (+ 80) ffffffff800aea0e <kernel_x86_64> kernel_debugger_internal (char const*, char const*, _va_list_tags, int) + 0x6e
4 ffffffff81dba7b0 (+ 256) ffffffff800aed72 <kernel_x86_64> panic + 0xb2
5 ffffffff81dba8b0 (+ 64) ffffffff80l55c0e <kernel_x86_64> x86_page_fault_exception + 0x1 8e
6 ffffffff81dba8f0 (+ 536) ffffffff80l4d142 <kernel_x86_64> mt_bottom + 0x56
kernel iframe at 0xffffffff81dbab08 (end = 0xffffffff81dbabd0)
rax 0x2 rbx 0xffffffff8233cdb8 rcx 0x1
rdx 0x26 rsi 0xffffffff8233cdb8 rdi 0x7fcbb4e2ee40
rbp 0xffffffff81dbac10 r8 0xffffffff8233cd98 r9 0xca8
r10 0xffffffff8233cda0 r11 0x46 r12 0x7fcbb4e2ee40
r13 0x6 r14 0xffffffff960677b8 r15 0x0
rip 0xffffffff8016b355 rsp 0xffffffff81dbabd0 rflags 0x10202
vector: 0xe, error code: 0x3
7 ffffffff81dbab08 (+ 264) ffffffff8016b355 kdebug>

Attachments (5)

GuitarApp_wizard_Browse.PNG (9.5 KB) - added by rose.kanari 4 months ago.
Kernel_debug.PNG (18.6 KB) - added by rose.kanari 4 months ago.
KDL_SC.PNG (51.5 KB) - added by rose.kanari 4 months ago.
Kernel_Team_2.PNG (78.1 KB) - added by rose.kanari 4 months ago.
Kernel_Team_2.2.PNG (78.1 KB) - added by rose.kanari 4 months ago.

Download all attachments as: .zip

Change History (15)

Changed 4 months ago by rose.kanari

Attachment: GuitarApp_wizard_Browse.PNG added

Changed 4 months ago by rose.kanari

Attachment: Kernel_debug.PNG added

comment:1 Changed 4 months ago by waddlesplash

Please retest on a recent nightly; this should provide the full backtrace at least (the one in this picture is cut off.)

comment:2 Changed 4 months ago by diver

Description: modified (diff)

comment:3 Changed 4 months ago by rose.kanari

Thank for your reply.

It seems linked to VMWare Workstation Player 15 (running and tested on Lenovo T570 and T580).
I try yesterday with the same vm on my other computer (Lenovo x230) running with the VMWare Workstation Pro 15.
I did not have a kernel panic.

I tried with :

1/ the lastest nightly version : "Haiku shredder 1 hrev52752"

  • VMWare Workstation Player 15 => kernel Panic
  • VMWare Workstation pro 15 => no kernel Panic. Guitar App terminates abnormally when I close it.

2/ version : "Haiku shredder 1 hrev52295+117 Nov 20 2018"

  • VMWare Workstation Player 15 => kernel Panic
  • VMWare Workstation pro 15 => no kernel Panic. Guitar App terminates abnormally when I close it.

PS : I will test tonight on the lenovo x230 with VMWare Workstation Player 15.

comment:4 Changed 4 months ago by waddlesplash

It's possible VMware Player doesn't support SMAP. Please post the image of the KDL on the nightly.

Changed 4 months ago by rose.kanari

Attachment: KDL_SC.PNG added

Changed 4 months ago by rose.kanari

Attachment: Kernel_Team_2.PNG added

Changed 4 months ago by rose.kanari

Attachment: Kernel_Team_2.2.PNG added

comment:5 Changed 4 months ago by waddlesplash

Owner: changed from nobody to korli
Status: newassigned

comment:6 Changed 4 months ago by rose.kanari

After install VMWare Workstation Player 15 on my Lenovo x230 (i7-3520M) I don't encounter any Kernel Panic.

Lenovo T570 and T580 are very close materially. (same processor i5 7200U, GPU HD620, RAM 16 ...) Same OS version.

In vmware log : I have this error on T570/T580 OvhdMem OvhdUser_BusError

I provide in new attachement the full backtrace ( I hope )

comment:7 Changed 4 months ago by korli

Did you try to disable SMAP in the bootloader menu?

comment:8 Changed 4 months ago by rose.kanari

Yes (disable SME & SMAP) or/and (SMP) I tried in the virtual machine settings with one CPU => Kernel Panic

Finally, I tried on my Synology DS718+ : disable SME & SMAP) or/and (SMP) and/or one cpu => Kernel panic

So "Haiku shredder 1 hrev52752"
vmware 15 on my lenovo x230 => No kernel panic with Guitar app
vmware 15 on my lenovo T570 or T580 => kernel panic with Guitar app
On my Synology => kernel panic with Guitar app

comment:9 Changed 4 months ago by rose.kanari

Hello,

I have uninstalled FuseSMB. (Why ?!? I don't know.)

https://github.com/orangejua/fusesmb-haiku

I don't have anymore Kernel Panic.

comment:10 Changed 7 days ago by waddlesplash

Blocked By: 14969 added
Resolution: duplicate
Status: assignedclosed

OK, so this is a dupe of #14969 then.

Note: See TracTickets for help on using tickets.