Opened 16 months ago

Closed 7 months ago

Last modified 3 months ago

#14969 closed bug (fixed)

[UserlandFS] SMAP violation in Volume::ReadAttr

Reported by: kim1963 Owned by: korli
Priority: normal Milestone: R1/beta2
Component: File Systems/UserlandFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14823
Platform: All

Description

SMAP violation rev53000 64 bit

Using SMB Network on desktop.

Attachments (9)

photo_2019-03-20_14-00-30.jpg (96.9 KB ) - added by kim1963 16 months ago.
listdev.txt (2.2 KB ) - added by kim1963 16 months ago.
sysinfo.txt (7.2 KB ) - added by kim1963 16 months ago.
photo_2019-03-21_10-49-45.jpg (80.0 KB ) - added by kim1963 16 months ago.
photo_2019-03-21_10-49-51.jpg (153.0 KB ) - added by kim1963 16 months ago.
photo_2019-03-24_12-42-50.jpg (151.3 KB ) - added by kim1963 16 months ago.
photo_2019-03-24_12-43-03.jpg (78.9 KB ) - added by kim1963 16 months ago.
IMG_20190602_172256.jpg (4.7 MB ) - added by bga 13 months ago.
SMAP KDL Debug
P_20191124_162919_HDR.jpg (2.7 MB ) - added by kim1963 8 months ago.

Change History (26)

by kim1963, 16 months ago

by kim1963, 16 months ago

Attachment: listdev.txt added

by kim1963, 16 months ago

Attachment: sysinfo.txt added

comment:1 by waddlesplash, 16 months ago

Owner: changed from nobody to korli
Status: newassigned

comment:2 by korli, 16 months ago

Please reproduce and try "area -m 0x0007ffffffffff", replacing 0x0007ffffffffff with the user-mapped address. Then "team 0xff", replacing 0xff with the owner from the area command output. And then

This should help to identify the user memory being passed to the kernel, but I suspect it's a user stack.

comment:3 by korli, 16 months ago

Looks like #14823 btw.

comment:4 by waddlesplash, 16 months ago

Why don't we get a full backtrace here?

by kim1963, 16 months ago

by kim1963, 16 months ago

comment:5 by korli, 16 months ago

kim1963, did you look at my comment https://dev.haiku-os.org/ticket/14969#comment:2 ?

by kim1963, 16 months ago

by kim1963, 16 months ago

comment:6 by waddlesplash, 15 months ago

@korli: I ran all the presumably-loaded kernel images through nm | haikuc++filt with the guarded heap enabled, and got no crashes whatsoever. So why are we getting read faults on demangling here?

comment:7 by korli, 15 months ago

@waddlesplash: I don't know.

comment:8 by kim1963, 15 months ago

UserlandFS leaks memory when watching video from smb and sshfs

https://dev.haiku-os.org/ticket/11975

comment:9 by waddlesplash, 14 months ago

Blocking: 14823 added

comment:10 by bga, 13 months ago

FWIIW, I am seeing this too. It is 100% reproducible (happens when trying to browse a share from Tracker). Disabling SMAP/SMEP makes it work (as expected) but sometimes I get some FuseSMB related crashes (last one was when scanning shares, I will create a bug) so I guess this might actually point to a more serious issue with FuseSMB or UserlandFS.

comment:11 by bga, 13 months ago

This is weird. It seems the kennel is accessing Tracker's memory? It makes sense somewhat as the crash happens when I try to open the smb network icon. I guess this is a userlandfs thing? Because nothing else makes sense

by bga, 13 months ago

Attachment: IMG_20190602_172256.jpg added

SMAP KDL Debug

comment:12 by waddlesplash, 8 months ago

Whoever can still reproduce this: Please run sc -d at the KDL prompt, and take a picture of it.

by kim1963, 8 months ago

Attachment: P_20191124_162919_HDR.jpg added

comment:13 by kim1963, 7 months ago

???

comment:14 by diver, 7 months ago

Component: - GeneralFile Systems/UserlandFS
Summary: SMAP violation rev53000 64 bit[UserlandFS] SMAP violation in Volume::ReadAttr

comment:16 by korli, 7 months ago

Resolution: fixed
Status: assignedclosed

merged, should be fixed in hrev53647. Please reopen if needed.

comment:17 by nielx, 3 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.