Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#14845 closed enhancement (fixed)

WebPositive settings - allow larger font sizes (easy)

Reported by: smallstepforman Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: DPI Font setting Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The largest font size configurable through WebPositive Font settings is 18. For Hi-DPI monitors, that maximum is generally too small. Instead of a BOptionPopUp, maybe a Spinner is the preferred interface (to match System Fonts preference).

However, at this point in time I'd also be happy if font sizes up to 32 were to be added to the popup.

Attachments (1)

screenshot1.jpg (1.6 MB) - added by smallstepforman 4 months ago.
Screenshot

Download all attachments as: .zip

Change History (8)

comment:1 Changed 4 months ago by pulkomandy

Summary: WebPositive settings - allow larger font sizesWebPositive settings - allow larger font sizes (easy)

comment:2 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Done in hrev52824.

comment:3 Changed 4 months ago by smallstepforman

A new regression - the settings are not applied :) Rev: 52824 Adjust spinner values to a higher value (eg. 24). The Font settings menu happily accepts the changes. However, none of the browser pages will actually use the new font settings. In the previous version (before this commit), the browser would actually use the new font settings (up to a maximum of 18).

comment:4 Changed 4 months ago by waddlesplash

There was a WebKit upgrade yesterday unrelated to my change to WebPositive. Testing locally on a machine with my patch but without the WebKit upgrade shows that the spinners work just fine; so it must be a regression in the new WebKit. Please open a separate ticket.

comment:5 Changed 4 months ago by waddlesplash

Just retested with WebKit 1.6.8 and it still works fine. So, I don't know what's going on for you then.

Changed 4 months ago by smallstepforman

Attachment: screenshot1.jpg added

Screenshot

comment:6 Changed 4 months ago by smallstepforman

Augustin, you need to open a new TAB which will use the new font size. If you use the current tab, then it uses whatever session settings are active. Take a look at the new attachment (screenshot1.jpg), which shows a much smaller default font size, even though I've requested 20 pixel font.

comment:7 Changed 4 months ago by waddlesplash

Yes, it seems there's some problem with how we handle fonts; but that's not this ticket's problem, my change works as intended. I just retested with the older build and it worked fine. So, please open a new ticket as this is a different regression.

Note: See TracTickets for help on using tickets.