Opened 18 months ago

Closed 5 months ago

Last modified 3 months ago

#14848 closed bug (fixed)

Installer layout broken in self build Haiku

Reported by: s40in Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Applications/Installer Version: R1/Development
Keywords: nominated-blocker Cc: nielx
Blocked By: Blocking:
Platform: All

Description

Installer layout broken in self build Haiku. No buttons are visible.

See screen.

Attachments (1)

installer_layout_broken.png (12.4 KB ) - added by s40in 18 months ago.

Download all attachments as: .zip

Change History (8)

by s40in, 18 months ago

Attachment: installer_layout_broken.png added

comment:1 by diver, 18 months ago

Component: - GeneralApplications/Installer
Keywords: installer removed
Summary: Installer layout broken in self build HaikuInstaller layout broken in self build Haiku

comment:2 by waddlesplash, 18 months ago

Probably an Interface Kit layout bug.

comment:3 by nielx, 10 months ago

Cc: nielx added
Keywords: nominated-blocker added

comment:4 by pulkomandy, 10 months ago

It's probably the same bug affecting TeamMonitor and a few other places. BTextView changes its size constraints during layout and the window size limits are not updated accordingly. You can easily reproduce this with any view using GetHeightForWidth to force a minimal height, since this is called after the first layout pass (width is known already)

comment:6 by waddlesplash, 5 months ago

Resolution: fixed
Status: newclosed

Fix merged in hrev53806.

comment:7 by nielx, 3 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.