Opened 8 months ago

Closed 8 months ago

#14859 closed bug (duplicate)

DriveSetup can't see partitions

Reported by: kuparikettu Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk/ATA Version: R1/beta1
Keywords: MBR Cc:
Blocked By: #5196 Blocking:
Has a Patch: no Platform: x86

Description

I have been testing Haiku (R1/beta1, Sep/2018) on my Thinkpad X41 from USB stick. Unfortunately I'm unable to install it, as it seems that Haiku is unable to see partitions on my main HDD. DriveSetup is able to recognize the HDD, a 16 Gb CF card, but in DriveSetup it shows up as one long grey bar and it isn't possible to do any changes to it from within Haiku.

On the CF card there are four partitions, made and formatted in Debian 9:

  1. ext4
  2. Linux swap
  3. fat32
  4. BFS

This computer is an older 32bit laptop. The CF card hasn't been used in any other more recent computers.

I tried the latest nightly build (hrev52815) but was unable to test for this bug due to encountering another (older?) bug: https://dev.haiku-os.org/ticket/14400

Attachments (1)

syslog (326.1 KB ) - added by kuparikettu 8 months ago.

Download all attachments as: .zip

Change History (5)

comment:1 by diver, 8 months ago

Please attach your syslog.

by kuparikettu, 8 months ago

Attachment: syslog added

in reply to:  1 comment:2 by kuparikettu, 8 months ago

Replying to diver:

Please attach your syslog.

Sorry, now attached :)

comment:3 by waddlesplash, 8 months ago

Component: Partitioning Systems/IntelDrivers/Disk/ATA
KERN: ata 0-0: model number: SDCFHS-016G                             
KERN: ata 0-0: serial number:      DAZ072617175521
KERN: ata 0-0: firmware rev.: HDX13.04
KERN: ata 0-0: using DMA mode 0x15
KERN: ata 0: identified ATA device 0
KERN: ata 0: probing device 1
KERN: ata 0 error: device 1 failed, error code is 0x00
KERN: ata 0: signature of device 1: 0x0000
KERN: ata 0 error: device ready not set
KERN: ata 0-1 error: sending identify request failed
KERN: ata 0 error: command failed, error bit is set. status 0x51, error 0x04
KERN: publish device: node 0x82c90e00, path disk/ata/0/master/raw, module drivers/disk/scsi/scsi_disk/device_v1
KERN: ata 0-0 error: invalid target lun 1 for ATA device
KERN: ata 0-0 error: invalid target lun 2 for ATA device
KERN: ata 0-0 error: invalid target lun 3 for ATA device
KERN: ata 0-0 error: invalid target lun 4 for ATA device
KERN: ata 0-0 error: invalid target lun 5 for ATA device
KERN: ata 0-0 error: invalid target lun 6 for ATA device
KERN: ata 0-0 error: invalid target lun 7 for ATA device
KERN: ata 0 error: target device not present
KERN: ata 0 error: invalid target device
KERN: Last message repeated 12 times.

comment:4 by waddlesplash, 8 months ago

Blocked By: 5196 added
Resolution: duplicate
Status: newclosed

Dupe of #5196.

Note: See TracTickets for help on using tickets.