Opened 2 months ago

Closed 8 weeks ago

#14921 closed bug (duplicate)

Instant reboot when booting with ACPI enabled

Reported by: kstabel Owned by: tqh
Priority: normal Milestone: Unscheduled
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: #14784 Blocking:
Has a Patch: no Platform: All

Description

Hi,

I'm getting instant reboots on an AMD A10-9700 based system. The system itself is a lenovo ideacentre 510 with 8 GB of ram.

I have attached a serial debug log.

Attachments (1)

minicom.cap (57.7 KB) - added by kstabel 2 months ago.
Serial debug log of boot

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by kstabel

Attachment: minicom.cap added

Serial debug log of boot

comment:1 Changed 2 months ago by CodeforEvolution

Well, just by looking at the top of your system log, I can immediately tell there’s some sort of memory corruption happening when apic is trying to be set up. That’s all I know.

comment:2 in reply to:  1 Changed 2 months ago by kstabel

Replying to CodeforEvolution:

Well, just by looking at the top of your system log, I can immediately tell there’s some sort of memory corruption happening when apic is trying to be set up. That’s all I know.

That's a baud rate mismatch. This happens in the bootloader. Once the kernel starts to come up, it has the correct baud rate.

comment:3 Changed 8 weeks ago by kstabel

Applied latest firmware (BIOS) update. Did not fix the issue.

comment:4 Changed 8 weeks ago by tqh

That's a new one, so last message is when registering power button. You can probably blacklist it at boot by holding SHIFT or SPACE while booting and find and blacklist the powerbutton driver. Would be quite interesting to know if that helps..

comment:5 Changed 8 weeks ago by kstabel

Hi tqh,

Tried replying by email, but doesn't show up, so apologies if this ticket gets updated twice now.

I tried blacklisting acpi button and battery, and it did come up, but it's still quite unstable. I get these messages right before it dies:

slab memory manager: created area 0xffffffffa6801000 (9923)
slab memory manager: created area 0xffffffffa7001000 (10026)
slab memory manager: created area 0xffffffffa7801000 (10064)
slab memory manager: created area 0xffffffffa8001000 (10115)
slab memory manager: created area 0xffffffffa8801000 (10150)
slab memory manager: created area 0xffffffffa9001000 (10205)
slab memory manager: created area 0xffffffffa9801000 (10261)
slab memory manager: created area 0xffffffffaa001000 (10307)
slab memory manager: created area 0xffffffffaa801000 (10341)
slab memory manager: created area 0xffffffffab001000 (10342)

I did notice acpi_task eating up quite a bit of CPU when it does come up with ACPI enabled. I can't strace it to see what's going on, though ...

comment:6 Changed 8 weeks ago by tqh

Blocked By: 14784 added
Resolution: duplicate
Status: newclosed

Ouch, Linux has a completely different ACPI driver for Ideapads and most likely IdeaCentre. This hardware was only intended to run Windows, and needs someone with motivation to fix and workaround all the bad things in their setup. Unfortunately I won't be able to work on this, but if anyone can/wants to I can probably help with advice.

This is a duplicate of #14784

Note: See TracTickets for help on using tickets.