Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#14922 closed bug (fixed)

boot regression xhci related

Reported by: korli Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #14924
Has a Patch: no Platform: All

Description

14263044aac31fb9b570850708a3c29a4f44f95d boots OK

7b53b3c2e49005cd02ca61c1f39d340267d52760 doesn't boot

Attachments (1)

SAM_7105_small.JPG (824.4 KB) - added by korli 2 months ago.
KDL screenshot

Download all attachments as: .zip

Change History (7)

Changed 2 months ago by korli

Attachment: SAM_7105_small.JPG added

KDL screenshot

comment:1 Changed 2 months ago by waddlesplash

It paniced in snooze()? That doesn't seem to make any sense. Are you sure my changes broke it?

comment:2 Changed 2 months ago by korli

I agree, it's weird. However I double checked, 14263044aac31fb9b570850708a3c29a4f44f95d boots OK, while c409803d6f4a0577547c05938c6fecd1a43aec4a doesn't.

The XHCI controller is a Fresco Logic FL1009 (1b73:1009).

comment:3 Changed 2 months ago by waddlesplash

I guess hrev52916 and then the lock added in 358dd70e161e0faf8159ff178f3ebd7dd07ba7f4 (just pushed) may be relevant somehow. At least I got panics due to elements of Device being NULL without the first commit.

comment:4 Changed 2 months ago by waddlesplash

Blocking: 14924 added

comment:5 Changed 2 months ago by korli

Resolution: fixed
Status: newclosed

fixed in hrev52922

Note: See TracTickets for help on using tickets.