Opened 12 years ago

Closed 7 years ago

#1493 closed bug (fixed)

The networkstatus app closes

Reported by: lxstoian Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc: EdwinGuy+Haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The network status app closes when the desktop bar is on the buttom of the screen and u try to view the info. The cause is that when u open it the quit button is pressed. Maybe the button should be moved up the menu.

Attachments (1)

1493.avi (430.8 KB) - added by scottmc 8 years ago.
a short video capture showing the network status closing when click on when the deskbar is at the bottom of the screen

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by RandomInsano

Cc: EdwinGuy+Haiku@… added
Component: - GeneralApplications/Tracker

Frankly, this should be set as an enhancement for the entire deskbar.

When the Deskbar is locked to the bottom of the screen to emulate Windows or even if there's a context menu being opened that's too low for the menu to appear at the bottom right of the cursor, the menu is instantiated in a location that has one of it's items selected.

Two ways of fixing this for NetworkStatus are to have the menu appear for Deskbar applets on click event, and not on mouse-down, or actually do better logic on where the context menu should appear. Both should really be done.

Also, sort order of the window options should be inverted while the Deskbar is locked to the bottom so that you don't need to scroll past 'Hide all', 'show all', 'close all' to get to the windows.

These seem like easy fixes, so I want to try and tackle them once classes are done for winter break. If anyone else wants to beat me to it though, feel free :)

comment:2 Changed 10 years ago by axeld

Component: Applications/TrackerApplications
Resolution: fixed
Status: newclosed

Fixed in hrev28832. At least I don't think there is a general problem that a menu item is preselected; it only shouldn't be invoked once you released the mouse button.

Since we already somehow turned off support for those pop-up, I guess we should make the "openAnyway" parameter meaningless for BPopUpMenu::Go(), too.

comment:3 Changed 10 years ago by RandomInsano

Resolution: fixed
Status: closedreopened

The problem still persists as of hrev28841. Dock the deskbar onto the bottom of the screen and perform a fast click on the icon. It will close NetworkStatus. ProcessController behaves as it should; pausing briefly before instantiating the menu.

comment:4 Changed 8 years ago by scottmc

Component: ApplicationsApplications/Deskbar
Version: R1/pre-alpha1R1/Development

Still present in hrev38581.

Changed 8 years ago by scottmc

Attachment: 1493.avi added

a short video capture showing the network status closing when click on when the deskbar is at the bottom of the screen

comment:5 Changed 7 years ago by kallisti5

Resolution: fixed
Status: reopenedclosed

tested no longer an issue as of hrev43862 gcc4

Note: See TracTickets for help on using tickets.