Opened 4 weeks ago

Closed 7 days ago

Last modified 7 days ago

#15029 closed bug (duplicate)

USB Media_Checker: Uninitialized lock crash

Reported by: miqlas Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: #14949 Blocking:
Has a Patch: no Platform: All

Description

No other info available

Attachments (3)

Change History (14)

Changed 4 weeks ago by miqlas

Changed 4 weeks ago by miqlas

comment:1 Changed 4 weeks ago by waddlesplash

Is this reproducible?

comment:2 Changed 4 weeks ago by miqlas

once happend so far i think.

comment:3 Changed 3 weeks ago by waddlesplash

Resolution: not reproducible
Status: newclosed

comment:4 Changed 3 weeks ago by xanadu

I had at least 3 crashes with this error in the last 2 days. It happened usually after I unmounted a USB thumb drive.

Last edited 3 weeks ago by xanadu (previous) (diff)

comment:5 Changed 3 weeks ago by waddlesplash

Resolution: not reproducible
Status: closedreopened

Okay. Can you find a more reliable way of reproducing it?

comment:6 Changed 3 weeks ago by xanadu

Not yet. It seems to occur randomly. The next time I'll take a picture of the error message.

Changed 3 weeks ago by xanadu

comment:7 Changed 3 weeks ago by xanadu

Et voilà!

Actually it's a different error in my case: Failed to acquire spinlock.

I copied a folder with files to a USB thumb drive I formatted with FAT32 under Haiku. After unmounting it I pulled it from the USB outlet of my PC. See the screenshot above.

comment:8 Changed 3 weeks ago by waddlesplash

It's probably the same bug.

comment:9 Changed 8 days ago by waddlesplash

So, I managed to hit this, and I'm not sure how I did it either. I do note that the KDL seems continuable, so just type co at the prompt the next time you hit it, and copy out and then attach your syslog here immediately following if you run into it again. I'll try to investigate more.

comment:10 Changed 7 days ago by waddlesplash

Blocked By: 14949 added
Resolution: duplicate
Status: reopenedclosed

Turns out this is a dupe of #14949.

comment:11 Changed 7 days ago by waddlesplash

I fixed this in hrev53141.

Note: See TracTickets for help on using tickets.