Opened 12 years ago

Closed 12 years ago

#1517 closed bug (duplicate)

registrar crash during boot

Reported by: marcusoverhagen Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by marcusoverhagen)

Application crashes during boot with gcc 2.95, on core 2 duo 2.4 GHz Occured with hrev22394

INIT: Bootscript started
reading page from store 0x9098a940 (cache 0x90992b00) returned: Device/File/Resource busy!
vm_page_fault: vm_soft_fault returned error 'Device/File/Resource busy' on fault at 0x410f24, ip 0x410f24, write 0, user 1, thread 0x39
vm_page_fault: sending team "/boot/beos/system/servers/regis" 0x2f SIGSEGV, ip 0x410f24 ("libbe.so_seg0ro" +0x1c8f24)
stack trace:
  0x003f8213 (libbe.so_seg0ro + 0x1b0213)
  0x003f796e (libbe.so_seg0ro + 0x1af96e)
  0x003cbae1 (libbe.so_seg0ro + 0x183ae1)
  0x003e7b3f (libbe.so_seg0ro + 0x19fb3f)
  0x003eea78 (libbe.so_seg0ro + 0x1a6a78)
  0x003ee6cf (libbe.so_seg0ro + 0x1a66cf)
  0x00312138 (libbe.so_seg0ro + 0xca138)
  0x0050fa40 (libroot.so_seg0ro + 0x20a40)
  0x70143fec (create_app_meta_mime (s)_39_sta + 0x3ffec)
vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x80098b64, write 0, user 0, thread 0x39
user_debug_exception_occurred(): Failed to install debugger: thread: 57: Bad port ID
54: DEBUGGER: You need to have a valid app_server connection first!
debug_server: Thread 54 entered the debugger: Debugger call: `You need to have a valid app_server connection first!'
stack trace, current PC 0xffff0102  :
  (0x7ffe6cac)  0x2cd73b  __Q28BPrivate13AppServerLink + 0x73
  (0x7ffe6cdc)  0x2c90a5  _._12BApplication + 0x69
  (0x7ffe6d1c)  0x20d53d  _._9NetServer + 0xa9
  (0x7ffe6d4c)  0x20c484  main + 0x6c
  (0x7ffe6f7c)  0x209267  _start + 0x5b
  (0x7ffe6fac)  0x1007ae  (runtime_loader_seg0ro + 0x7ae)
debug_server: Killing team 54 (/boot/beos/system/servers/net_server)
debug_server: TeamDebugHandler::Init(): Failed to get info for team 54: Operation on invalid team
debug_server: KillTeam(): Error getting info for team 54: Operation on invalid team
debug_server: Killing team 54 ()     
intel_extreme: init_hardware()
intel_extreme: init_hardware() failed: No such file or directory
matrox: init_hardware() failed: General system error
neomagic: init_hardware() failed: General system error
Radeon - init_hardware: Version: 5.1.6.0
Radeon - Radeon_CardDetect: no supported devices found
radeon: init_hardware() failed: General system error
savage: init_hardware - no supported devices
s3savage: init_hardware() failed: General system error
vesa: init_hardware()
vesa: init_driver()
vesa: publish_devices()
vesa: find_device()
loaded driver /boot/beos/system/add-ons/kernel/drivers/dev/graphics/vesa
via: init_hardware() failed: General system error
vesa: vesa_init() completed successfully!
vesa: acc: vesa.accelerant
                              

Attachments (1)

tracker_boot_crash.txt (149.4 KB) - added by marcusoverhagen 12 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by marcusoverhagen

Description: modified (diff)

another boot, this time Tracker crashed

vesa: vesa_init() completed successfully!
vesa: acc: vesa.accelerant
reading page from store 0x90a206e0 (cache 0x90a22380) returned: Device/File/Resource busy!
vm_page_fault: vm_soft_fault returned error 'Device/File/Resource busy' on fault at 0x609004, ip 0x10351c, write 0, user 1, thread 0x53
vm_page_fault: sending team "/boot/beos/system/Tracker" 0x53 SIGSEGV, ip 0x10351c ("runtime_loader_seg0ro" +0x351c)
stack trace:
  0x00103599 (runtime_loader_seg0ro + 0x3599)
  0x00101b21 (runtime_loader_seg0ro + 0x1b21)
  0x00102377 (runtime_loader_seg0ro + 0x2377)
  0x0010253c (runtime_loader_seg0ro + 0x253c)
  0x00100782 (runtime_loader_seg0ro + 0x782)
  0x7ffe6fec (/boot/beos/system/Tracker_main_ + 0xffffec)
vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x80098b64, write 0, user 0, thread 0x53
debug_server: Thread 83 entered the debugger: Segment violation
stack trace, current PC 0x10351c  (runtime_loader_seg0ro + 0x351c):
  (0x7ffe6edc)  0x103599  (runtime_loader_seg0ro + 0x3599)
  (0x7ffe6f0c)  0x101b21  (runtime_loader_seg0ro + 0x1b21)
  (0x7ffe6f3c)  0x102377  (runtime_loader_seg0ro + 0x2377)
  (0x7ffe6f6c)  0x10253c  (runtime_loader_seg0ro + 0x253c)
  (0x7ffe6fac)  0x100782  (runtime_loader_seg0ro + 0x782)
emuxki: init_hardware() 

comment:2 Changed 12 years ago by marcusoverhagen

And another crash, again Tracker during boot, full debug output attached.

Changed 12 years ago by marcusoverhagen

Attachment: tracker_boot_crash.txt added

comment:3 Changed 12 years ago by axeld

Ah, that's a simpler one: if the inode cannot be locked (because it's written to), the vnode store's operation may now fail (since my latest changes...). I should probably sit back and think this through again :-)

comment:4 Changed 12 years ago by bonefish

Resolution: duplicate
Status: newclosed

Duplicate of #1509.

Note: See TracTickets for help on using tickets.