Opened 5 months ago

Last modified 4 months ago

#15204 reopened bug

Allow logins to gerrit without github accounts

Reported by: nephele Owned by: haiku-web
Priority: low Milestone:
Component: Sys-Admin Version:
Keywords: ldap, gerrit, trac Cc:
Blocked By: #12750 Blocking:
Has a Patch: no Platform: All

Description

Personally i simply do not have a github account, and neither do i wish to have one,

I'd think that allowing my dev.haiku-os.org account to be used would be perfect.

Change History (5)

comment:1 by kallisti5, 5 months ago

Component: Website/GerritSys-Admin
Keywords: ldap gerrit trac added
Owner: changed from kallisti5 to haiku-web
Priority: normallow

While rolling out Gerrit, I did consider going with a locally hosted unified auth solution. However our resources are limited and github had a low bar to entry (all of our developers had github accounts)

I don't see an easy way to "use trac accounts" given the way trac works. (I also don't trust Trac to hold all of our sensitive user data). We might be able to deploy an ldap server and migrate to it as a common data source for user accounts, however "moving existing accounts over to ldap" is a tricky procedure, we would need to import the accounts and offer some kind of self-service to reset passwords. We would also need to fill GDPR requirements while we're at it.

With all of that said, we have quite a few other *large* projects in flight (builbot repairs / replacement, online.net iSCSI being sketchy) which have the potential of blocking R1 / R1 Beta 2 if not done. The priority of this one is low at the moment.

Last edited 5 months ago by kallisti5 (previous) (diff)

comment:2 by luroh, 5 months ago

It is unfortunate that the reporter brought up single sign-on in this ticket as that's a quite orthogonal issue, already tracked in ticket:12750.

comment:3 by kallisti5, 5 months ago

Blocked By: 12750 added
Resolution: duplicate
Status: newclosed

Good point! This one is indeed a duplicate of #12750

comment:4 by nephele, 5 months ago

I brought it up as a potential path to go to, not as a problem in and of itself, I don't know whether it is a good idea to have the same account for i.e haikudepot and tracker as that other issue mentions though.

comment:5 by pulkomandy, 4 months ago

Resolution: duplicate
Status: closedreopened

I would prefer we keep this open, even if indeed single sign-on is one way to solve this (unless all other services switch to "login with github"...).

Note: See TracTickets for help on using tickets.