Opened 5 months ago

Last modified 3 weeks ago

#15207 new bug

HaikuDepot / pkgman cannot fully update my system

Reported by: konrad Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: #15068 Blocking:
Has a Patch: no Platform: x86-64

Description

As I no longer can use Parallells for my Haiku camping I decided to go with Qemu (using HVF acceleration).

  1. When starting HaikuDepot I got a warning and it doesnt show any categories.
  2. When using pkgman full-sync it find packages that needs to be updated (seems to be same revision of the packages) but it fails (see attached screenshot).

Attachments (2)

Skärmavbild 2019-07-28 kl. 10.26.07.png (623.8 KB ) - added by konrad 5 months ago.
HaikuDepot warning
Skärmavbild 2019-07-28 kl. 10.26.17.png (906.1 KB ) - added by konrad 5 months ago.
pkgman fails

Download all attachments as: .zip

Change History (8)

by konrad, 5 months ago

HaikuDepot warning

by konrad, 5 months ago

pkgman fails

comment:1 by diver, 5 months ago

Did you use Installer to copy existing installation? If so it could be a regression from #15145.

comment:2 by waddlesplash, 5 months ago

Blocked By: 15068 added
Component: Applications/HaikuDepotKits/Package Kit
Keywords: pkgman removed
Milestone: R1/beta2Unscheduled
Owner: changed from stippi to nobody

No, this is not that bug, but rather the pkgman error is #15068. However, the question remains as to why the Package Kit is trying to update packages to the exact same version that is already installed. I've seen this happen before too... Can you check the time in the VM?

comment:3 by konrad, 5 months ago

Time (date command) reports the same time as my host. But I had to use GMT or set the clock +2 hours. (Yes I selected correct time zone).

comment:4 by Begasus, 4 weeks ago

Getting the same error, maybe because I installed a local build package with some fixes (and the same name to be updated)? Also tried moving to GMT and correct timezone, checked date in Terminal, all looks OK, but still fails.

comment:5 by Begasus, 4 weeks ago

Checked this, did a "pkgman update <package>" and that worked, checked in between with "pkgman full-sync" with the same error until I was down to 1 package "lcms", this was one I updated a while back and installed it on my system and is giving me the error. I can't just uninstall it as it will take down multiple packages relying on it. PS, had it before with texmaker, uninstalling that worked and full-sync was OK with it.

comment:6 by diver, 3 weeks ago

As a stop-gap solution you can just copy-paste downloaded package (from transaction folder) to /system/packages, replacing the one you already have there with the same name. Ignore package_daemon alert and reboot. That should do it.

Note: See TracTickets for help on using tickets.