Opened 11 months ago

Closed 6 weeks ago

#15266 closed bug (invalid)

[atheroswifi] does not find wifi networks

Reported by: BlackXanthus Owned by: waddlesplash
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/atheroswifi Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #15695
Platform: All

Description (last modified by diver)

Running on 32bit Haiku O/S, on current nightly build (18th August, 2019).

Under previous builds, the wifi controller would find the networks, and connect successfully.

In the most recent nightly build we get this:

~>ifconfig /dev/net/atheroswifi0/down
~>ifconfig /dev/net/atheroswifi0/up
~>ifconfig /dev/net/atheroswifi0/scan
name                         address            signal     auth
~>

Extract from syslog:

KERN: wlan_control:9235,78
KERN: wlan_control:9235,76
KERN: wlan_control:9235,78
KERN: wlan_control:9235,76

[---edit---]

KERN: wlan_control:9235,16
KERN: wlan_control:9235,17
KERN: wlan_control:9235,28
KERN: wlan_control:9235,98
KERN: wlan_close(0xe314ec00)
KERN: [net/atheroswifi/0] stop running, 1 vaps running
KERN: [net/atheroswifi/0] ieee80211+new+state+locked: SCAN -> INIT (nrunning 0 nscanning 0)
KERN: [net/atheorswifi/0] down parent
KERN: [net/atheroswifi/0] ieee80211_newstate_cb: SCAN -> INIT arg -1
KERN: [net/atheroswifi/0] sta_newstate: SCAN -> INIT (-1)
KERN: [net/atheroswifi/0] node_reclaim: remove 0x811160000<f0:7b:cb:61:c9:7e> from station table, refcnt 2
KERN: [net/atheroswifi/0] [f0:7b:cb:61:c97e] ieee80211_alloc_node: inact_reload 2

[--snip-]

KERN: ieee80211_notify_scan_done
KERN: wlan_control: 9234, 76

The message: KERN: wlan_control: 9234, 76 (with similar numbers) is repeated throughout the log. 

Thanks,

BX

Change History (5)

comment:1 by WildKeccak, 5 months ago

Some networks or all networks?

comment:2 by diver, 5 months ago

Component: - GeneralDrivers/Network/atheroswifi
Description: modified (diff)
Owner: changed from nobody to waddlesplash
Summary: AtherosWifi does not find wifi networks[atheroswifi] does not find wifi networks

Please post your complete syslog.

comment:3 by diver, 5 months ago

Probably a dupe of #15695?

comment:4 by waddlesplash, 3 months ago

Blocking: 15695 added

comment:5 by waddlesplash, 6 weeks ago

Resolution: invalid
Status: newclosed

No reply to request for syslog.

Note: See TracTickets for help on using tickets.