Consider renaming dprintf?
|Reported by:||jessicah||Owned by:||nobody|
dprintf is now a part of POSIX.1-2008, so we probably shouldn't overload the use of this function.
Came up from running lgtm.com on the Haiku tree, as POSIX
dprintf takes an extra argument.
Given it's mainly exported from KernelExport.h, it could be safe to do a mass rename to something better, even if it is public API. I'm sure we could retain binary compatibility if we keep a forwarding definition but rename the declaration. Thoughts?
LGTM alerts: https://lgtm.com/projects/g/haiku/haiku/alerts