Opened 10 years ago

Last modified 5 months ago

#4929 assigned enhancement

Rename dprintf() to Avoid Clash with the POSIX.1-2008 Function

Reported by: bonefish Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking: #15366
Has a Patch: no Platform: All


POSIX.1-2008 introduces the functions [v]dprintf(). To avoid a name clash when we implement them, the kernel dprintf() should be renamed to debug_printf(). We can continue provide the old symbol for binary compatibility.

Change History (5)

comment:1 by waddlesplash, 5 years ago

Milestone: R1Unscheduled

comment:2 by waddlesplash, 5 years ago

Milestone: UnscheduledR1

Reverting earlier milestone change

comment:3 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:4 by waddlesplash, 14 months ago

Why rename it to "debug_printf" instead of just "printf", anyway?

comment:5 by waddlesplash, 5 months ago

Blocking: 15366 added
Note: See TracTickets for help on using tickets.