Opened 12 years ago

Closed 5 years ago

#1557 closed bug (invalid)

Frequency out of range

Reported by: plfiorini Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by rudolfc)

This is the C51PV chipset.

Booting Haiku hrev22527 my screen becomes black after the Haiku splash screen and the monitor says the frequency is out range and I can't see anything.

Hardware: AMD 64 x2 with 2GB RAM Here's lspci output:

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:05.0 VGA compatible controller: nVidia Corporation C51PV 6150 (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
03:08.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1) 

Attachments (2)

syslog (85.6 KB ) - added by plfiorini 10 years ago.
haiku_nv_1.07.zip (89.6 KB ) - added by rudolfc 10 years ago.
nvidia driver 1.07: added fix for gf 6100/6150/6200 black screen

Download all attachments as: .zip

Change History (20)

comment:1 by umccullough, 12 years ago

Maybe you're experiencing the same as me: I've had problems with my integrated GeForce 6100 video - it yields a black screen for Haiku and Zeta - I suspect there's something wrong with the driver.

comment:2 by korli, 11 years ago

Did you try a fail safe video mode in the boot menu ?

comment:3 by mmlr, 11 years ago

Could this have been fixed with hrev27390?

comment:4 by mmlr, 11 years ago

Scratch that, I've misread the description. It seems to be happening after the splash screen, not during...

comment:5 by mmadia, 10 years ago

Owner: changed from axeld to rudolfc

comment:6 by rudolfc, 10 years ago

Hi there,

Is this bug still valid? If not, I'd like to close this ticket..

Bye!

Rudolf.

comment:7 by plfiorini, 10 years ago

Last time I checked it didn't happen with my new GeForce 8800GT (G92 based). I will try enabling the integrated chip later.

comment:8 by rudolfc, 10 years ago

Hi,

The GF8xxx series is not supported by the driver so this one is running in VESA mode and therefore doesn't give any insight I'm afraid.

I'm curious how the integrated chip holds then.. :-)

Bye!

Rudolf.

comment:9 by rudolfc, 10 years ago

Hi again,

Please upgrade to hrev32946. Does it work correctly now on the non GF8800 card? Please upload a log from that driverversion as well.

Thanks!

Rudolf.

comment:10 by rudolfc, 10 years ago

Hi there,

Please disregard the previous message and upgrade to hrev32958. Now the fix seems complete. Please test and let me know!

Thanks!

Rudolf.

comment:11 by plfiorini, 10 years ago

Version: R1/pre-alpha1R1/Development

It's not fixed, the monitor doesn't say out of range (it says so with openSUSE 11.1 though :) anymore but it's turned off. Attached latest syslog

by plfiorini, 10 years ago

Attachment: syslog added

comment:12 by rudolfc, 10 years ago

Ok, thanks for testing again!

BTW: will you be at Begeistert the coming weekend by any chance? I should be there, so if you are too, maybe you could bring that system along so I could test better..

Bye!

Rudolf.

comment:13 by plfiorini, 10 years ago

You are welcome!

I will attend at BeGeistert with other Italian guys but it would not be very comfortable to take this desktop machine with me, the trip is long by train (12 hours from Milan to Dusseldorf, 2 hours from my town to Milan) and it's my only modern desktop machine... :-(

See you at BG!!!

PS: Will you write a 2d/3d accelerated driver for G80/G92 chipsets if I will take a GeForce 8500 PCIe card with me? :)

comment:14 by rudolfc, 10 years ago

Hi again,

BG was nice!

In the meantime I bought a gf6200 to see if it could help me with this problem. There was indeed a related problem there which is fixed in nvidia driver 1.07 (hrev33966). I am uploading it to this ticket now.

Please test it and tell me how it holds up. Can you also please upload a logfile from it?

Bye!

Rudolf.

by rudolfc, 10 years ago

Attachment: haiku_nv_1.07.zip added

nvidia driver 1.07: added fix for gf 6100/6150/6200 black screen

comment:15 by mmadia, 10 years ago

Description: modified (diff)

comment:16 by rudolfc, 9 years ago

Description: modified (diff)

comment:17 by luroh, 9 years ago

plfiorini: any improvement here?

comment:18 by luroh, 5 years ago

Resolution: invalid
Status: newclosed

Closing as no longer valid due to lack of feedback. Rudolf's fix committed in hrev33966.

Note: See TracTickets for help on using tickets.