Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#1587 closed bug (fixed)

Segment Violation in Painter::StraightLine()

Reported by: scottmc Owned by: stippi
Priority: high Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

While debugging #1479 on my thinkpad 570E I was able to get it to boot up with the crazy color video reported in #1169 and then set the video mode to 1024x768, 16bit color and reboot. It them boots up to a blue screen with a working hand cursor but after about 10 seconds drops to GDB with this error:

[tcsetpgrp failed in terminal_inferior: Invalid Argument] Thread 110 caused an exception: Segment violation Reading symbols yada yada.... ... ... ... Reading symbols from /boot/beos/system/add-ons/accelerants/neomagic.accelerant [tcsetpgrp failed in terminal_inferior: Invalid Argument]

[Switching to team /boot/beos/system/servers/app_server (42) thread w:68:Terminal 1 (110)] 0x002922ca in Painter::StraightLine () (gdb)

Note that I typed this in by hand so might be typos. This was with hrev22697. I will attach serial debug as well.

Attachments (5)

r22697-m7118-serial-debug2-segviolation.txt (53.1 KB) - added by scottmc 12 years ago.
sc231007.txt (99.9 KB) - added by meanwhile 12 years ago.
GDBHaikur22724.png (120.9 KB) - added by meanwhile 12 years ago.
r22736debug.txt (92.1 KB) - added by meanwhile 12 years ago.
screen.png (158.1 KB) - added by meanwhile 12 years ago.

Download all attachments as: .zip

Change History (20)

Changed 12 years ago by scottmc

comment:1 Changed 12 years ago by axeld

Component: - GeneralServers/app_server
Owner: changed from axeld to stippi
Priority: normalhigh

comment:2 Changed 12 years ago by bonefish

Summary: Segment violation [tcsetpgrp failed in terminal_inferior: Invalid Argument]Segment Violation in Painter::StraightLine()

comment:3 Changed 12 years ago by meanwhile

I've a similar situation with a similar Thinkpad (570), maybe the serial debug from it can help as there are similarities in them as well.

Changed 12 years ago by meanwhile

Attachment: sc231007.txt added

comment:4 Changed 12 years ago by scottmc

Sometimes when booting up it hangs with a black screen and the Haiku logo. Serial debug shows it hanging at: via: init_hardware() failed: General system error

never getting to the next line, unless I try rebooting: ps2_hid: init_hardware

So it seems there might also be an issue with ps2_hid: init_hardware as well.

meanwhile do you see this same thing happening on your 570?

comment:5 Changed 12 years ago by meanwhile

In the setup here (two BeOS partitons and a Haiku partition, managed by Bootman) each Haiku revision has always hung at its bootscreen after a reboot from one of the BeOS installs.

Restarting from Haiku also doesn't work: the cursor freezes at the stage in the restart process where the message 'Asking other processes to quit' is displayed. When choosing shutdown instead and then clicking the 'Restart System' button in the 'System is Shut Down' window, the cursor also freezes.

Just found that a reboot from BeOS into Haiku gives

"via: init_hardware() failed: General System error"

as the last line of the debug output here too.

At this point I can't reboot though; if you could let me know how you reboot to get to the next line ?

comment:6 Changed 12 years ago by meanwhile

BTW, this was all done with hrev22509. I'll get the latest revision in the next days to see if #1479 changed things here too.

comment:7 Changed 12 years ago by meanwhile

As for restarting from Haiku, the reboot gets further in hrev22724: it now hangs at Haiku's bootscreen. However, except for the successfull very first boot of this revision, a next boot of it gives a GDB screen (see attachment).

Changed 12 years ago by meanwhile

Attachment: GDBHaikur22724.png added

comment:8 in reply to:  7 Changed 12 years ago by scottmc

Replying to meanwhile:

As for restarting from Haiku, the reboot gets further in hrev22724: it now hangs at Haiku's bootscreen. However, except for the successfull very first boot of this revision, a next boot of it gives a GDB screen (see attachment).

OK so it sounds as if both of our systems are doing the exact same thing. First boot hangs, and then a second boot attempy boots up but then drops to GDB with the Painter::StraightLine() seg fault. I'm not sure but this might be 2 or 3 bugs. Anyways we're here to test. Bug one would be why does it hang at "via: init_hardware() failed: General System error" or is it hanging on the ps2 command which is next? Bug two is this ticket, the Painter::StraightLine(). Anyone else seeing this or is it just with Neomagic chipset or just Thinkpad 570 series? A listdev of a 570E can be seen in ticket #1169.

comment:9 Changed 12 years ago by stippi

Could you try if you still get the crash in Painter::StraightLine() with hrev22736?

My suspicion is that the graphics driver and/or accelerant are not being initialized properly, and the Painters are not attached to the frame buffer correctly. I don't really know though. Would be great to have such a machine to test... but maybe not me but someone able to maintain the Via driver...

comment:10 Changed 12 years ago by meanwhile

Tried it with hrev22736, but it still behaves the same. Maybe the debug info tells more... (see r22736debug.txt). Since last week I have a second TP 570, so it wouldn't hurt so much to see one of them leave for a testing period.

Changed 12 years ago by meanwhile

Attachment: r22736debug.txt added

comment:11 Changed 12 years ago by meanwhile

Clarification: Now only at the third boot there's a GDB screen showing. The hrev22736.txt is the serial debug output; what shows at this 3rd boot is seen in 'screen.png'.

Changed 12 years ago by meanwhile

Attachment: screen.png added

comment:12 Changed 11 years ago by meanwhile

scottmc: maybe you want to have another try with hrev23281 (or later), because here this bug seems solved.

comment:13 Changed 11 years ago by scottmc

I just put hrev23287 on the Thinkpad 570E and this bug seems to be gone now, so OK to close.

comment:14 Changed 11 years ago by stippi

Resolution: fixed
Status: newclosed

Hm. I am not sure if I understood the original bug, but if you can't reproduce it anymore... :-)

comment:15 Changed 11 years ago by meanwhile

Thanks nevertheless, stippi. I'm tempted to put an easy "typical IBM quirk" label on it...

Note: See TracTickets for help on using tickets.