Opened 11 years ago

Closed 11 years ago

#1603 closed bug (duplicate)

Media server crashes on shutdown

Reported by: el-al Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Servers/media_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I get the following error every time I shutdown my system:

"The application: /boot/beos/system/servers/media_server

has encountered an error which prevents it from continuing...."

If I then proceed to click the Debug button on the dialog, the dialog disappears and I am then able to use the Restart System button on the underlying 'System Is Shutdown' dialog in the normal way. I am expecting to see debug output but (obviously) the system has almost completed its shutdown procedure so is unable to produce any output.

This problem has been around on this system for a while now, so goes back way beyond a revision that I can recall.

Test system is using a standard Audigy soundcard (which is configured in Prefs -> Media as using Emuxki In and Out/Channel 0. It is a P4 1.8 Ghz + 520 Mb Rambus memory.

This behaviour is also reproducable by Enabling Real-Time Audio in Media ->Prefs. Debug output is available here although I can't mail it to myself due to connection problems (so I will transcribe the relevant bit here:

[tcsetpgrp failed in terminal_inferior:Invalid Argument] Thread 78 caused an exception: Segment violation ... ... ... [tcsetpgrp failed in terminal_inferior:Invalid Argument] [Switching to team /boot/beos/system/servers/media_server (78) thread media_server (78) 0x00656450 in ??()

This seems to me to be the only useful bit.

And lastly, enabling Real-Time Audio does not persist over a re-boot although the setting survives a re-start of the media server (via the prefs panel).

Attachments (2)

gdb.txt (2.5 KB) - added by mt 11 years ago.
GDB log
syslog (79.4 KB) - added by mt 11 years ago.
syslog file

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by mt

Hi el-al, My machine has been same bug. (I used SB live value.)

media_server crashes on shutdown or force quit by ProcessController I will attached log of force quiting.

Changed 11 years ago by mt

Attachment: gdb.txt added

GDB log

Changed 11 years ago by mt

Attachment: syslog added

syslog file

comment:2 Changed 11 years ago by marcusoverhagen

Resolution: duplicate
Status: newclosed

this is a duplicate of bug #1112

Note: See TracTickets for help on using tickets.