Opened 12 years ago

Closed 10 years ago

#1627 closed bug (fixed)

FAT: General System Error!

Reported by: rdmr Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/FAT Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can't copy from a FAT file system to my Haiku partition anymore. I can't open them also. While copying, Tracker shows "General System Error!" message and creates file with 0 bytes. I could copy or open it before, but not anymore.

Tested with hrev22950.

Change History (10)

comment:1 by nielx, 12 years ago

What was the last known revision that worked for you?

in reply to:  1 comment:2 by rdmr, 12 years ago

Replying to [comment:1 nielx

What was the last known revision that worked for you?

The latest build i was able to copy files from FAT was hrev22840. After this build I didn't test any other revisions until hrev22950. So i looked up the commits between hrev22840 - hrev22950 and saw that some file systems are ported to a new API or so if I understand correctly. Maybe it's related to that.

comment:3 by nielx, 12 years ago

The changes between those two revisions were:

hrev22886 - Initial changes to the filesystem cache

hrev22901 - "The "bytes" as passed to {read|write}_file_io_vec_pages() was never initialized, causing those functions to read|write a random amount."

hrev22913 - Changes to the file map.

The author of those changes was axeld, so the component owner remains unchanged.

comment:4 by pieterpan, 12 years ago

Accompanying syslog entry:

2007-11-21 11:56:23 KERN: file_cache: read pages failed: General system error

comment:5 by kaoutsis, 12 years ago

some info that might be helpful: mounted a fat partition with hrev24158, although i can't read existing files, i can cd into directories, view the contents; i created a new file successfully, then i wrote something in it, and after that, i could read it, but only this file :)

comment:6 by rdmr, 12 years ago

additional info that may help (i hope):

I was able to mount a ntfs partition and was able to read any file(hrev24238). So it seems like a bug in fat driver.

comment:7 by luroh, 10 years ago

rdmr, pieterpan: is the ticket still valid?

comment:8 by rdmr, 10 years ago

Sorry, forgot to inform about this ticket. I didn't get any error for almost a year. So this can be closed.

comment:9 by PieterPanman, 10 years ago

Ah, yes, I think it is ok now. I cannot find any usb stick, but it mounts my ipod fine.

comment:10 by anevilyak, 10 years ago

Resolution: fixed
Status: newclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.