Opened 12 years ago

Closed 12 years ago

#1631 closed bug (fixed)

Reboot failure if video color depth set less than 32 bits per pixel

Reported by: gerald zajac Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

If a video mode with a color depth less than 32 bits per pixel (e.g. 8, 15, or 16 bpp) is set, it works fine until the computer is rebooted. Then Haiku crashes during reboot, and you wind up in gdb. This is not unique to any particular video driver, since this has happened consistently with the Savage4, NVidia TNT2, and Matrox G550 video cards that I have tried. This problem was found in hrev22950, but may have existed in previous revisions.

Change History (2)

comment:1 Changed 12 years ago by axeld

Component: - GeneralServers/app_server
Milestone: R1R1/alpha
Priority: normalcritical

I can easily reproduce this problem over here.

comment:2 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev22971.

Note: See TracTickets for help on using tickets.