Opened 9 months ago

Closed 9 months ago

#16349 closed bug (duplicate)

Network App - Gateway lost after disabling and re-enabling a NIC

Reported by: Coldfirex Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Preferences/Network Version: R1/beta2
Keywords: Cc:
Blocked By: #9695 Blocking:
Platform: All

Description (last modified by Coldfirex)

Howdy, I noticed that when I disable a NIC (via ifconfig or the Network app), and then re-enable it that the gateway is never put back. This is the case when using DHCP or a static IP address.

If I switch to a different mode (for instance from DHCP to static an back to DHCP) then the gateway is picked up.

Screenshot: https://imgur.com/a/LXqQB59

Virtualbox, NAT mode, and Intel Pro.

Change History (4)

comment:1 by vidrep, 9 months ago

Sounds like a duplicate of https://dev.haiku-os.org/ticket/9695

comment:2 by Coldfirex, 9 months ago

Description: modified (diff)

comment:3 by Coldfirex, 9 months ago

Yep, you are right.

comment:4 by waddlesplash, 9 months ago

Blocked By: 9695 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.